Jump to content
Ultimate Subaru Message Board

Recommended Posts

My heater blower has been acting kinda strange since last winter. I've finally gotten a chance to do some work on it. Here's the lowdown: if the engine is cold, the blower will COME ON and STAY ON indefinitely as long as I don't turn off the ignition. Works fine at all blower speeds. If, for instance, I stop by a gas station and turn the ignition off with the engine warmed up, the blower will not come on after I restart the car. I have tried to jump voltage to the blower while the engine is warm and the blower will run fine. I removed the resistor pack but I don't know how to test them. My resistor pack consists of three open coils, not the glass tube kind that I have read about in other posts.

Any ideas?

Share this post


Link to post
Share on other sites

Since the speed are working ok then resistors are good. Just make sure there are no faulty connections. There is a blower relay in the dash near the radio area. It may be the first of four relays. You could try tapping it while the problem is occuring or swap it with another one if it fits correctly.

Share this post


Link to post
Share on other sites

Before I had a chance to check the relay, I bumped the resistor pack coils and one broke. They are very brittle. Does anybody know where to find another pack?

Share this post


Link to post
Share on other sites

A little tin foil works too.As long as current flows through it with they'll work,regardless of the amount of that ceramic goop.

 

 

As for the relays,I believe you need to find the one with the larger diameter (heavier guage) blue wires going to it.I don't have my manuals handy so someone correct me if I'm wrong.

 

I've had relays go,motors,resistor packs and I've always been able to get them going again with minimal trouble.

Share this post


Link to post
Share on other sites

I may try to solder the coil back together, but I think the solder won't stick to the brittle coils. They broke in a couple of places. Where exactly do I find these relays for the blower?

Share this post


Link to post
Share on other sites

You really can't repair these. It is best to just get a new set from a dealer. The relay should be near the radio area and may be the first of four as I mentioned in my first post.

Share this post


Link to post
Share on other sites

the local Autozone had a resistor pack for 41 bucks. It's on order. How exactly does one go about testing a relay to determine if it is ok? I'll try to get back when I get the resistor in and the relays checked.

Share this post


Link to post
Share on other sites

I found the relay under the steering column behind the dash. It was sticking. Had to tap it with a screwdriver to get it to work.

Share this post


Link to post
Share on other sites

Glad you found it and got it to go. You may have to end up replacing it later. The screwdriver tap trick is one of my favorites.

Share this post


Link to post
Share on other sites

I went online and ordered two new relays. From what I gather (I could be wrong), the four relays in that aree are the same 12v 22A relays. If any of the others go bad I will have a spare. I found that my '86 EA82 uses the same part number relay as the earlier EA81 models (both 12v 22A), but the EA81 relays cost 10 bucks while the EA82 relays cost 15 bucks. Both have the same shape so they will tuck away under the dash nicely. I bought the cheaper relays figuring that as long as the specs are the same and the part numbers are the same, both will work.

Share this post


Link to post
Share on other sites

I have the exact same problem. Heater fan works for the first few minutes of operation, then if you turn the car off, no fan.

 

I also happen to have an 86. Mind telling me where exactly the relay is? I would like to limit what I have to take apart to find it.

 

Also, any chance the relay is a autozone/pepboys/checker/etc part?

Share this post


Link to post
Share on other sites

That makes THREE OF US! ""Heater fan works for the first few minutes of operation, then if you turn the car off, no fan""

Please help, are there any write-ups, stickies, or web links to help find the relay, or facilitate the job?

:)

 

 

I have the exact same problem. Heater fan works for the first few minutes of operation, then if you turn the car off, no fan.

 

I also happen to have an 86. Mind telling me where exactly the relay is? I would like to limit what I have to take apart to find it.

 

Also, any chance the relay is a autozone/pepboys/checker/etc part?

Share this post


Link to post
Share on other sites

My '86 used to do that too. I could get mine back on by giving it a good thump under the glovebox (where the blower motor is). It was a fun trick, especially when you ask your passenger to kick the car, but it didn't last too long.

 

I ended up with a new (a la junkyard) blower motor and a new relay. Check for voltage at the blower motor. Mine had a bad relay thus no voltage. It also had eaten the brushes in the blower motor.

 

The relays are in a little bracket behind the frontside of the dash just under the steering wheel. You'll need to remove the panel under the steering wheel and unscrew the fuse box to reach it. It's hard to see, but you can feel the relays. They are about 1" in diameter and semi-cylindrical. The ones with the black wires coming out are for your headlights. If you headlights work, borrow one to check the one for the blower motor.

Share this post


Link to post
Share on other sites
That makes THREE OF US! ""Heater fan works for the first few minutes of operation, then if you turn the car off, no fan""

Please help, are there any write-ups, stickies, or web links to help find the relay, or facilitate the job?

:)

 

I figured it out. It is under the kick panel immediately under the steering wheel/fuse area. You should take the screws off to lower the entire panel.

 

It is up near the steering area. You will see several cylindrical relays up there, held in with spring clips. It is one of those. I just started swapping relays (they are all the same part)until my heater fan kicked on, and replaced the one that was in there. No more heater issues

Share this post


Link to post
Share on other sites

Thanks Newsance, I will be giving this a try. Add it to the list...altho this one will creep up in priority! Where did you get the correct relay? Subaru stealer?

 

Blake

 

 

I figured it out. It is under the kick panel immediately under the steering wheel/fuse area. You should take the screws off to lower the entire panel.

 

It is up near the steering area. You will see several cylindrical relays up there, held in with spring clips. It is one of those. I just started swapping relays (they are all the same part)until my heater fan kicked on, and replaced the one that was in there. No more heater issues

Share this post


Link to post
Share on other sites

I got one at my local checker, although they had to go to a catalog to find it. The systems didn't give them a part listing. Still, once they idenitifed it, they had it in stock.

Share this post


Link to post
Share on other sites

Ok, thanks -- I guess I'll try the local Sucks, Autozone or Napa. Thanks for the reply and tips.

Blake

 

 

I got one at my local checker, although they had to go to a catalog to find it. The systems didn't give them a part listing. Still, once they idenitifed it, they had it in stock.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×