Jump to content
Ultimate Subaru Message Board
Sign in to follow this  

Recommended Posts

Does anyone know what size speaker is in the dash of a '78 Brat? I am replacing it, but don't want to change anything else. Thanks

Share this post


Link to post
Share on other sites
Does anyone know what size speaker is in the dash of a '78 Brat? I am replacing it, but don't want to change anything else. Thanks

 

You might have to score a new style speaker,unless you either get a good used speaker or somehow find one somewhere in a dealer's old stock(nearly impossible).

 

The speaker is the same from Stage II 1977 through 1979 for all models.I have to think it stayed the same through the remaining first generation Brat (1981).

 

An earlier sedan,etc would be different as far as part number.As for the exact size and maybe connector difference I'm not sure.

 

I think it's about 2.5 x 5 inches....but it's just a guess.Good luck.Please let us know what you find to replace it with.

Share this post


Link to post
Share on other sites

IIRC, its a 4"x6" Clarion speaker. I'll have to look to see if I have the one from my '78 Brat still since I stripped the dash in order to big it more "up to date"

Share this post


Link to post
Share on other sites

Well, I had a new speaker put in and I'm not sure about it. I was all excited when I picked it up, but I think I will end up having to take it back for a different one. It sounds great if the volume isn't too high. But, when I turn it up a little, it sounds like crap. All fuzzy and blurry sounding. A bit of a disappointment.

Share this post


Link to post
Share on other sites

Check the ground, make sure nothing is interfering with the conection,

 

Sometimes this will make the speaker whine and crackle.

 

Also good quality speakers have a higher range so your able to turn the volume up with less disortion.

Share this post


Link to post
Share on other sites

I think that's the problem. I kept telling them that I want a GOOD speaker, but I don't think they understood. I asked to hear what it sounded like, but they didn't have connected. It sounds like it's pretty weak. I'll wait till after the weekend and go back to see what they say.

Share this post


Link to post
Share on other sites

This could be an impedance problem

 

If the output transistors are looking for 4 ohms and you give them 8

 

they might not be too happy.

 

This problem will manifest itself especially at larger outputs.

 

I 'avent a clue as to what impedance these radios are set up for.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×