Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
Brettm57

Help! My Legacy wagon rear hatch won't open!

Recommended Posts

Neither the electric release or the door handle will open the rear hatch/door of my '96 Legacy wagon. Is there a way to release the latch? It feels like it came unhooked inside. I'm guessing I'll have to take the whole inside hatch panel off to open it. But I'm hoping one of you know a trick that will release the latch without doing that. Thanks for your help.

Share this post


Link to post
Share on other sites

Simple to open the interior panel as I remember just climb into the back compartment, pop the clips from the bottom and sides and you should be able to see that an arm has become detached from a pivot point or attachment. Actually, it's probably easier to move the lever by hand and once you open the hatch, work on it like a biped standing upright instead of a worm slithering around the back of the car.

Share this post


Link to post
Share on other sites

Brettm57,

 

You've been given good advice by Brus Brother, but May I add one small change? Once in the back of the car you can just grab the tailgate panel and pop it off its plug fasteners....along its sides, across its top, and on the two or three that are in the middle of the panel....but not across its bottom. You won't be able to get to those plugs until you get the door open, since they fasten into the bottom panel of the door. BUT you should still be able to get inside to the lock mechanism to unlock the door after the top, side and middle plugs are unfastened, just don't bend the panel back too far because of the bottom plugs. You sure don't want to break the panel. Good Luck!

Share this post


Link to post
Share on other sites

Before removing the inside panel, try this just in case.

1) Lock the gate.

2) Push on the gate handle towards the front of the car.

3) Still holding the handle pushed forward, unlock the gate with your key.

4) Pull on the handle.

If this works, report back and I'll tell you the rest of the story. If not, you've already got good advice on how to trouble shoot.

Share this post


Link to post
Share on other sites
Damn frag, now i want to know the story.

 

Quite simple story. The hatch latch mechanism works that way : there is a lever that the handle catches when you pull on it to open the hatch. Locking the hatch has the effect of pushing this lever aside and out of the handle's way (you then pull on the handle and nothing happens, nothing catches). Unlocking puts this lever back in front of the handle so it catches when you pull on the handle.

When the handle mechanism becomes rusted the resistance becomes too much for the spring that brings back the handle towards the car. So when you unlock you put back the lever not in front of the handle but BEHIND it. You then pull on the handle and nothing happens till you do what I prescribed a couple of post before. A more permanent solution is of course to lubricate the mechanism with a anti-rust oil till the spring can once more automaticaly bring the handle back towards the hatch afer usage. Mine has been rusted since the moment i bought the car used but annual application of the proper lubricant has solved the problem for now.

Share this post


Link to post
Share on other sites

Apparently the problem with my car is the electric lock isn't always releasing. I've got the key lock freed up now so I can unlock it that way if necessary, plus I oiled everything up while I had the interior panel off. It seems to be working OK now. Thanks again for your advice.

Share this post


Link to post
Share on other sites

what frag said happens to my '99 rusted POS legacy wagon all the time. its goin back in the shop today after CEL came on and started burning oil and smoking quite bad this morning. only have 90k on it had HG's done once and im sure thats what the problem is again. yup its the aweful 2.5 engine as well. sorry just venting.

Share this post


Link to post
Share on other sites

you my friend are wonderfull my newly purchased out back hatch would not open tried your suggestion thinking no way must be linkage murphys law but your wonderfull tip worked thanks

Before removing the inside panel, try this just in case.

1) Lock the gate.

2) Push on the gate handle towards the front of the car.

3) Still holding the handle pushed forward, unlock the gate with your key.

4) Pull on the handle.

If this works, report back and I'll tell you the rest of the story. If not, you've already got good advice on how to trouble shoot.

Share this post


Link to post
Share on other sites
you my friend are wonderfull my newly purchased out back hatch would not open tried your suggestion thinking no way must be linkage murphys law but your wonderfull tip worked thanks

 

Thanks for reporting back! Lots of people here try to help and it's a joy when we learn it was not in vain. Lots of other times we do our best and miss the target.

Share this post


Link to post
Share on other sites
You can adjust the rod length and make it a permanent fix.

Not if it is binding due to corrosion (rust). Frag, I had to do the same thing on my 92 Legacy when I first got it. I came up with the solution after noticing that the handle was not releasing all the way. The car had also been rear-ended, and when I was given the car, it was with a non-functional rear hatch. . . Total repair time was an hour (I also had to pull the latching ring towards the back of the car so the hatch indicator would go out when the door closed. . .) and regular lubrication. Seems this is a fairly common problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×