Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
sanada

91 Justy: problem starting on warmed engine...

Recommended Posts

i just completed an engine overhaul on my 91 Justy. i have adjusted the throttle-sensor and replaced the fuel pump. when i start the car cold, car starts and runs well. but when engine has been warmed up, it is difficult to start the car again unless i cool the car down. can someone tell me whats wrong and how i can solve this problem.

 

thanks

Share this post


Link to post
Share on other sites

I'd guess the coolant temperature sensor (CTS) is bad. No idea where it's located on a justy though.

 

Would be cheapest to replace from a junkyard; I believe dealers want big $$$ for them.

Share this post


Link to post
Share on other sites
what does it do when it wont start?

 

 

nipper

 

nothing.. i have to sit and wait till the engine cools before i can started up again.

Share this post


Link to post
Share on other sites

Update ..... thanks a lot for your info. you point out problem like magic. WHAT A WISE! I put a new CTS in this morning, Justy starting well on any temperature and running well. Thanks again.

I'd guess the coolant temperature sensor (CTS) is bad. No idea where it's located on a justy though.

 

Would be cheapest to replace from a junkyard; I believe dealers want big $$$ for them.

Share this post


Link to post
Share on other sites
Update ..... thanks a lot for your info. you point out problem like magic. WHAT A WISE! I put a new CTS in this morning, Justy starting well on any temperature and running well. Thanks again.

 

awesome, glad it was an easy fix.

 

-Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×