Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
Mr. Carb

Heater controls in an XT

Recommended Posts

I posted this on the xt6.net board, but theres diffrent people there and here so I'd thought I'd throw this out here too see what people think is going on.

 

My temp control slider has been working smoothly and fine sense I got the car. This is a 1986 XT turbo 4wd. Suddenly the other day, I went to move the slider from the hot position to the cold position. And now it won't go back into the hot position. It feels like the cable maybe slipped, I'm not sure. But it sticks when sliding back to the hot position. It always blows cold now, if it's all the way in the hot position, I can feel like the heater flap is almost opening as a slight amount of heat mixed with cold outside air blows through. I can hear a flap moving when I push it to the cold position, but the slider hits a stopping point mid way through the cool air section, and it will not go all the way forward like it used to. Did something fall apart in there? or has the cable just slipped on me? I'm hoping I won't have to tear out all of the dash to get this fixed.

 

Thank you for this boards vast knowledge! :)

Share this post


Link to post
Share on other sites

Well, bad news. The center console needs to come out. The clamp that holds the cable most likely came loose and the only way to get to it is to remove the console. Kind of detailed to remove, in other words, a PITA. If you want to come to my place, I can help you do it.

And btw, most of the folks from XT6.net are here also.

Share this post


Link to post
Share on other sites

Ok, I have to remove the center councle anyway so I can put my fog light switch in. :cool:

 

I checked the cable linkage on the heater box. The gear the cable moves appears to be jammed. I can't get it to move very much. I'm tempted to pull the cable cover off and see if something fell in there jamming the gears. This did happen right after I put some wires through right above it for the fog light switch. I found out that 86 XT's don't have the stock places for fog lights, or the fog light wireing. It appears to be an 87 and newer XT thing.

 

But yeah, Maybe I'll be able to make it down tuesday evening, or sometime. Maybe I can take a peak at the ea81 turbo book you said you have too, and see if I can get the t-coup to run again.:)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×