Jump to content
Ultimate Subaru Message Board

Recommended Posts

I have this 90 Subie Legacy LS sedan auto that has intermittent heater blower usage.

Sometimes, but not most times it works fine.

The little green lites lite up when I push the frt defrost button or any for that matter and turn the fan on .

But most of the time nothin works.

I have checked the fuses and they are good - at least Im pretty sure I checked the right fuses.

Share this post


Link to post
Share on other sites

If the blower doesn't work on high speed then the motor is most likely going to need to be replaced or the relay is intermittent. You can check to make sure that voltage is getting to the motor connections when the trouble is happening to verify that it is the motor at fault. If the motor is ok then the problem may be due to a faulty blower relay.

Share this post


Link to post
Share on other sites

Thanx for the info.

The fan works on all settings , just doesnt work all the time.

Its like 2 out of 10 times itll work , aswell as the lights on the controls that indicate which setting it is in.

i.e. - defrost , floor , a/c

What fuse it connected to this part of the panel?

And is there a relay for that ?

Share this post


Link to post
Share on other sites

The problem is most likely due to a faulty relay and tapping it while the problem is occuring may get the motor going to prove that. Look for the relay under the dash on the left side. There are other relays their also. The blower relay has a neutral color connector going to it. The fuel pump relay has a green connector, ignition is brown, and sun roof is red.

 

The power to the blower through the relay is from fuse 21 and the control is through fuse 15.

Share this post


Link to post
Share on other sites
If it is the relay I have a few and can send you one for the cost of postage and a cup of coffee.......

hey blackbart we are going to have to meet one day. I see you bid on a lot of legacy's. I'll just getting back into a subaru. newly single with son in marines. what a test life is. hey what is the chance.

 

do you have a lsd 3.90- for a turbo SS. just put a used tranny in. had 61k miles on it. oh and do you have any mud flaps for the passenger side rear. have to get at you tomorrow. finishing up with watch. one day down the road I would like to switch over to a stick, just not yet.

 

I work in the city (new york) and live upstate in elizaville, that's near hudson new york. I enjoy weekend drives to new places and enjoy meeting new people. one other thing I've owned four subaru now, they are one of the best for taking a beating and keep on ticking.

 

what kind of seats fit the 91 legacy if you know? are wrx seats bolt in replacements?

 

be well and enjoy your weekend. daniel.barry@med.va.gov

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×