Jump to content
Ultimate Subaru Message Board
Sign in to follow this  

Faulty ignition coil & eng. revolution sensor?

Recommended Posts

Hello all...

well my '91 wagon (EA82 carby) won't turn over at the moment. Quite frustrating actually as I had pulled the entire dash to install an immobiliser and after putting it back together she won't fire! mind you, the alarm works perfect :-)


I've got the immobilser 'disabled' at the moment so I took that out of the picture.

The battery has been connected to a charger and is still pretty good.

All fusible links (3) and fuses intact.

When I try and start it I just get the starter motor but it won't turn over.


I did some tests and for some strange reason it looks like a couple of parts have failed...


When I try and start it there's no fuel supply to the carby. I jumpered the fuel pump though and it's working fine.

The fuel pump on mine is controlled by the Engine Revolution Sensor box, so I checked that and it's not putting out power to the fuel pump (blue wire, red trace from memory). With the possibility of it being fried, I opened it up and there's just a relay and a few passive components, nothing looks 'fried' either.


I also checked to see if I was getting a spark from the plugs... nothing there, but they looked a bit dirty.

The dizzy cap's got a bit of that white-powered corrosion so I bypassed that and connected a NEW spark plug direct to the ignition coil... still no spark!

There is voltage on both low-tension terminals of the coil so it appears the coil might be shot.


I'm hoping someone may be able to suggest any flaws in my 'tests', or otherwise shed some light on how these items may have suddenly died when the car has merely been in the garage for a week?

Thanks in advance :eh:

Share this post

Link to post
Share on other sites

Make sure your horn works. Another poster I helped out had the same symtoms you have and he had to replace the fuse for the horn. This fuse (#5 I believe), feeds power also too the ignition relay and hopefully is your problem. If this is ok then you may have a problem with the CAS (crank angle sensor) in the distributor. If the ECU does not see pulses coming from the CAS it will not turn on the ignition and fuel pump.


It may be the ignition relay also at fault but I suspect it is really ok. My manual for an '88 model, shows the relay is brown and between the steering wheel and radio area. Not sure if yours will be the same.

Share this post

Link to post
Share on other sites

Cougar: thanks for your suggestions.

As I mentioned, my suby has a carby, so no ECU. Instead there is this Revolution Sensor box which feeds power to the fuel pump. Power is going in to this, but not coming out.


Same goes for the ignition coil... power going in, but no spark.

Share this post

Link to post
Share on other sites

I would try to find out if pusles are coming from the CAS to the timing box. You may be able to use a test light to watch them but I am not sure if that would draw too much power from the circuit. It would be best to use a scope or possibly a analog meter will will work. I haven't tried it myself.

Share this post

Link to post
Share on other sites

Once again, I'm not sure if you're referring to an EFI vehicle, but I did get the problem sorted ;)


I swapped in another ignition coil and engine revolution sensor box (on my vehicle, this is located above the bonnet release on the A-pillar).

Still no start, so I used my digital multimeter to see if I could detect any activity coming from the ignition module in the distributor.


For those who aren't aware, on the carby EA82 the engine revolution sensor supplies power to the fuel pump when it detects pulses from the ignition coil, and the ignition coil gets fired by the ignition module in the distributor.

I didn't have access to the proper testing equipment but I could tell it was doing ~something~ so that was enough to convince me not to bother swapping in another dizzy.


By the way, the reason the car was off the road was to swap in the fancy dash from a tacho-equipped sedan. Everything appeared to be a direct plug-in, but I checked the main loom connections just to be sure.

I had forgotten to check one plug though! it connects the dash loom to the main car loom on the passenger side A-pillar.

This may not make a lot of sense, but my car's ignition coil had an extra wire connected to this plug, but on the dash from the sedan this same connection was wired to the dash lights (*shrugs*) It was essentially shorting out the ignition coil.

As the wire wasn't used with the car's original dash, I disconnected it.


Thanks again for your help Cougar.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this