Jump to content
Ultimate Subaru Message Board
GeneralDisorder

EA81 SPFI Conversion Manual ready for preview

Recommended Posts

MegaSquirt looks Bad Arse I was in love with that pick-up before I read more about it. dreamed of a twin turbo AWD rod and that makes it look easy. little pricey for the 87 GL FI conversion but Bad Arse none the less

Share this post


Link to post
Share on other sites

We have a couple other threads going about problems we encountered but have it all figured out and hopefully pass smog next week. let me know what you need and can go out and take pictures and send info as needed. Good Luck with your projects, it's worth it.

Share this post


Link to post
Share on other sites

I don't know if this has been covered before, but I just pulled the gauge cluster out of my '85 hatch and noticed a difference from the standard SPFI conversion outline. My ECS lamp is there and so is the speed sensor. However, there are two extra wires coming from the speed sensor. One wire is light blue and the other is white, both meeting in a blue, two pole connector.

 

What does this mean, and how do I work around it?

 

Also, my car does not have cruise control, but does have a Hitachi carb with an o2 sensor (I'm pretty sure).

Share this post


Link to post
Share on other sites
One wire is light blue and the other is white, both meeting in a blue, two pole connector.

 

What does this mean, and how do I work around it?

 

Those are the infamous 60,000 mile EGR switch leads. Ignore them. Use the other connector for the speed sensor per my write up.

 

GD

Share this post


Link to post
Share on other sites
I'm still tweaking things, and I still need to take some more pictures, but it's ready for people to pick it apart. Here ya go:

 

http://home.comcast.net/~trilinear/EA81_SPFI.html

 

Be prepared to do some reading....

 

As soon as I get another harness to convert, I'm going to enlarge the harness conversion section with a TON more pictures. The weather is keeping me from it right now, but that should change this next week I hope.

 

GD

 

This link doesn't work any more. Could you repost it?

Share this post


Link to post
Share on other sites

 

This link doesn't work any more. Could you repost it?

 

Bump. I'm considering this swap, and I knew the write-up was out there, and now the link is dead. I thought I saved it to my computer too, but I can't find it.

 

 

EDIT: Never mind, found it!!!

 

http://www.leoneturbo.com/docs/EA81_SPI_guide.pdf

Edited by Numbchux
  • Like 1

Share this post


Link to post
Share on other sites

Hi I got a ea82 multipoint fi engine on my trike need help with wireing it up .ie make harness for moter to start. Any suggestion apprecated daryl

Share this post


Link to post
Share on other sites

We didn't get SPFI at all in Australia but a few have imported a kit.

 

I bought one off a fellow Subie owner nearby. Apart from some sensors like the TPS and MAF being old and faulty it was workable and it ran but not 100%. My bad as I wasn't knowledgeable enough to get it running just right. Being in a regional area makes it hard too as no one has the know how to work on them in terms of wiring. Also the CR isn't the same on a stock ea81...8.7:1 (if in good order) compared to 9.5:1.

 

I had to file 2mm of alloy meat off the centre of the block halves to get the manifold to clamp down. Be careful, later on when the engine was reconditioned the builder told me I wasn't far off going too far with the filing.

 

In USA/Canada it would be much worth your while. In Oz not so much. Any part you need has to be imported. Hence I went for simplicity with the 32/36 and kept the SPFI manifold on. Goes great now.

Share this post


Link to post
Share on other sites

Daryl,

From reading your post, it seems that you're trying to get a MPFI engine to work. This thread was about the SPFI that wasn't available in Aus, so you might be better off starting a new thread, or looking on some local forums.

 

How much of the harness do you have currently? The MPFI cars have a different body loom, but only available for 2 years on the Leone, and longer for the XT/Vortex. FYI, the early Vortex (which black ECU) has a separate EFI loom (plus a few extra wires like wipers) which plugs into the rest of the harness (I'm not sure about the later models with gold ECU). My suggestion would be to try to find a wreck of one of those. The harness will need to be severely shortened as the ECU is mounted under the rear parcel shelf, but that's an easy job of cutting & resoldering.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×