Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
Guest Loki595

EGR valve or EGR Solenoid?

Recommended Posts

Guest Loki595

I have a 1994 Impreza that is Front Wheel Drive and has the 1.8 liter engine. My check engine light came on and I had my friend who is a mechanic scan it. He said that my Coolante Temp Sensor needed replaced, which I did, and that the light was on for the EGR System. I want to know if anyone here has had this happen and what would be easiest and cheapest to fix it. I am going to get my friend to vacuum check the hose, but I just was wondering if anyone thinks it is the solenoid or the valve. When I first start my car when it's cold, it will start after a few turns, but then it will idle at around 200 RPM, and I have no throttle response. After a minute I get some throttle response, but it still idles at around 200 to 300 RPM. Given another minute, the car is fine and everything is good. I was looking at what my friend said was the EGR and noticed that the diapragm doesn't move as well cold, once it warms up it's fine. If anyone knows about this please reply, I can send pics over e-mail of what the part in question looks like, I know my description is lacking. Thanks for any help.

Share this post


Link to post
Share on other sites
Guest Legacy777

It's probably sticking open.

 

I'd probably reset the ECU and see if the same code comes back relating to the EGR. If so, then it's probably the valve.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×