Jump to content
Ultimate Subaru Message Board
cd45

heater blower

Recommended Posts

Problem, the blower keeps going off. I replaced the blower motor, and that worked for a week. This morning, it went off in less than 10 miles. Is it the resistor or the relay? I know which one I hope it is but, I am sure it will be the expensive one.

Share this post


Link to post
Share on other sites
Problem, the blower keeps going off. I replaced the blower motor, and that worked for a week. This morning, it went off in less than 10 miles. Is it the resistor or the relay? I know which one I hope it is but, I am sure it will be the expensive one.

 

I just took a jumper wire from the wire on the back of the switch right to the blower motor. Then I replaced the block that was right on the bottom part of the Blower here is a the link to what I had going on.

 

http://www.ultimatesubaru.org/forum/showthread.php?t=84226

 

If you move down a bit you can see what I was talking about. I hope that helps you.

 

Jeff

Share this post


Link to post
Share on other sites

If the blower will work on high speed then the resistor block is bad. If it doesn't work at all then the relay or switch may be at fault, or also the motor.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×