Jump to content
Ultimate Subaru Message Board
Redcap

Half of my lift is built.

Recommended Posts

I saw your other thread... You should be able to get the blocks in, you are trying to get them in through the top, right? Can you move the strut around a bit to get them in? If nothing else, try taking the strut loose from the knuckle, and install the blocks on the strut, then put the strut in the car, and then re-attach the knuckle to the strut, then put the pivot bolt back in. Check to make sure you dont have something binding or hitting the axle, keeping it from going low enough to put the blocks in, I cant think of what could be wrong :confused:

 

-Bill

Share this post


Link to post
Share on other sites
I saw your other thread... You should be able to get the blocks in, you are trying to get them in through the top, right? Can you move the strut around a bit to get them in? If nothing else, try taking the strut loose from the knuckle, and install the blocks on the strut, then put the strut in the car, and then re-attach the knuckle to the strut, then put the pivot bolt back in. Check to make sure you dont have something binding or hitting the axle, keeping it from going low enough to put the blocks in, I cant think of what could be wrong :confused:

 

-Bill

 

I can move the strut around, but can't get enough space inbetween the body and top of the strut to fit the block in. I also can't get enough room to get the strut free from the knuckle! It looks like I'd have to pop the lower ball joint (something I am loathe to do). It doesn't look like anything is binding either. It is very strange.

 

I'm still a complete n00b when it comes to these cars, so here is a dumb question...there is a bar that attaches to the lower control arm with 2 bolts, it runs across diagonally and back to a mount on the body. Do I need to remove that instead of where the control arm attaches to the cross member? I'm just at a loss here.

 

I can provide pictures if needed. Any help is greatly appreciated as I need this car back on the road by Monday so I can take my son to school. It is my daily driver. :-\

Edited by Redcap

Share this post


Link to post
Share on other sites

Are you sure you unhooked your swaybar??? This seriously sounds to me like a case of "swaybar-f'ingyouupitis".

 

Pics would help, but, seriously; this should all go pretty easy. Especially if you have a fat friend handy... :lol:

Share this post


Link to post
Share on other sites
Are you sure you unhooked your swaybar??? This seriously sounds to me like a case of "swaybar-f'ingyouupitis".

 

Pics would help, but, seriously; this should all go pretty easy. Especially if you have a fat friend handy... :lol:

 

I pulled the link for the swaybar first thing (and will completely remove it later), but it didn't seem to help. I'll get pictures tomorrow when I get back to the barn, hopefully I've just been stupid and overlooked something...which was distinctly possible considering my level of tool-throwing frustration. :mad:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×