Jump to content
Ultimate Subaru Message Board
Ricearu

What Have You Done to your Soobie lately? (Please post in here and keep it going)

Recommended Posts

Redneck facebook as in CB radio?

 

I should have figured that out.

 

Rob, its not really a good facebook since no one else had one LOL! Talking to yourself?

Share this post


Link to post
Share on other sites
What...?

 

the cb you sent me Tom lol, oops shoulda read EVERYTHING

Edited by Subruise
im a doof

Share this post


Link to post
Share on other sites

It would be nice to get a CB for my car as well, may as well add a CB antenna to the ham antenna. Why not just start an antenna farm on the roof of my car :brow:

Share this post


Link to post
Share on other sites

so yesterday one of my recently installed struts decided to seporate from anything bolted to the knuckle and wipe out my ps axle, and dern near the tire as well with the spring perch. stupid used limey built struts......( i dont hate limeys but cmon, who spot welds things when you should lay a bead on that puppy like ALL my other ones) im just lucky it was at the end of the day and at less than 25 mph

Share this post


Link to post
Share on other sites

picture if you can....the inside of a tire coated in axle grease, and a strut w/o brackets. it even broke the brake line bracket. brakes are fine...so far. ill get some pics (and txt em to ya to post lol) tonight when i yank out the other strut.

Share this post


Link to post
Share on other sites

they had surface "rust" kinda peppered in there but i maintain that the welds, or lack thereof, led to premature failure. that or the air Crapwagon caught this weekend (oops). but then they shoulda failed wayy ealier this week.

Share this post


Link to post
Share on other sites

Replaced 4 yr old battery with Optima Redtop 25, 720 CCA.

 

Old battery kept dropping voltage, setting off the alarm or resetting the dash clock or putting the Kenwood radio into protect mode. Suspected it was a cell shorting out - load test confirmed this.

Share this post


Link to post
Share on other sites
Replaced 4 yr old battery with Optima Redtop 25, 720 CCA.

 

Old battery kept dropping voltage, setting off the alarm or resetting the dash clock or putting the Kenwood radio into protect mode. Suspected it was a cell shorting out - load test confirmed this.

 

I have had mine since 2003 or 2004 and it's been in 5 different Subarus, and still starts strong even in the cold. I have a feeling you'll like it!

Share this post


Link to post
Share on other sites
I heard the new Optima batteries have gone downhill so I took them off my list.

 

I talked to my parts man about the same thing - apparently they've improved their quality control in manufacturing. Good news.

Share this post


Link to post
Share on other sites

Fixed the windshield wipers, heater fan and instrument lighting.

It is quite nice to not only see how fast I am going but also where I am going ;)

 

I don't know which was more "invigorating" standing on my head to reach the relays up in and under the drivers side dash or dissembling the whole thing from left to right to find them in the first place.

 

The manual by Haynes does not give their location.

 

The manual by Chilton does not even acknowledge their existence in text or in the wiring diagrams.

Share this post


Link to post
Share on other sites

I took mine apart to get to the timing cover o-rings that were dumping oil out at a rate of about a quart per 100 miles. :eek:

 

 

103_2168.jpg

 

 

 

Ordered parts on Friday, they'll be in tomorrow, hopefully be all sealed up and back together by Wednesday! :D

Share this post


Link to post
Share on other sites

BRAT had the drainplug on the radiator disentigrate....ugh. After a couple trips to Napa, Orielly, and finally Autozone its obvious that my radiator is NOT from an 86 Brat (though it works great, and fits like a glove), and that the part number for the actual one (Dorman 61114) is NOT what I need. What I did was a 12 1.25 oil drain plug w/ rubber washer...works like a charm of course. Now, what the hell is this radiator, lol...because ALL the other subaru's I lookup up from that era all used that same Dorman that doesn't fit? hmmm...wierd....

Share this post


Link to post
Share on other sites

I kindly suggest you to Post a couple of Photos -in different angles- of your Radiator here; so we could see it and maybe someone could identify it for you.

 

Kind Regards.

Share this post


Link to post
Share on other sites

Drove 2000 miles moving from CO to FL....

Averaged 33mpg and the only hiccup (if you can call it that) was having to add about 2qts of oil during the trip. Gotta re-seal that EA, or do an EJ swap. Bumped the mileage up to 236k with that drive.

 

2k miles; no a/c; no cruise control; one very distressed kitty :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×