Jump to content
Ultimate Subaru Message Board
Ricearu

What Have You Done to your Soobie lately? (Please post in here and keep it going)

Recommended Posts

The old wagon got a shot of paint and a little camo  its a 20/20 paint job but it sure is shiny, and now I got beef with the mud at my old wheelin spot i think she neets a few rock chips will post pics later today and mabey some dirty subi photos...lol :brow:

Edited by marcusgl10z28
  • Like 1

Share this post


Link to post
Share on other sites

The old wagon got a shot of paint and a little camo  its a 20/20 paint job but it sure is shiny, and now I got beef with the mud at my old wheelin spot i think she neets a few rock chips will post pics later today and mabey some dirty subi photos...lol :brow:

where is this spot???? im down for some local wheelin, and im sure im not the only one

Share this post


Link to post
Share on other sites

About This:
 

... I swapped to the LEDs... but I think 2 aren't working correctly as it doesn't even look like they are illuminated... I used the correct bulbs, but oh well, could be worse.
 
AfterOilChange_zpsdd9f7561.jpg
 
...

 
Remember that LED Bulbs does Have Polarity (+/-) So, if they doesn't Lit, Remove their Socket from the Instrument Cluster, Turn it 180º and place it there again.

 

Feel Free to Share your LED Bulb Retrofitting Photos & Experiences in this Discussion Thread about that Subject:

 

~► http://www.ultimatesubaru.org/forum/topic/69467-ea82-dashboard-backlights-upgrade-to-hid-white-led%C2%B4s/page-6

 

Kind Regards.

  • Like 1

Share this post


Link to post
Share on other sites

I reinforced my rear crossmember a bit.

 

Put some 3mm thick square tube in and weld it in place:


SAM_1408.JPG

 

After welding the ends of the crossmember tube I painted it black and sprayed a coat of stone chip guard to it:

 

SAM_1413.JPG

 

And tomorrow it will hopefully replace this one:

 

SAM_1352.JPG

 

Oh and I did some braces into the inside of crossmember mounts too. And I did weld the square pipe into the inner parts by slicing it open and welding it together with the crossmember. I hope it stays together for a while now :)

Edited by -tombba-

Share this post


Link to post
Share on other sites

Wow, it just rusted right through? I live in the desert so, I never see rust like that. However, I do see a different type of rot - interior rot. The sun is brutal on interiors here in the desert.

Share this post


Link to post
Share on other sites

Wow, it just rusted right through? I live in the desert so, I never see rust like that. However, I do see a different type of rot - interior rot. The sun is brutal on interiors here in the desert.

 

Yep. It's a common problem that they rust in finland since the long winter and road salt. But hat one mut have be the wors one I've ever seen. It was broken from both sides like that and the last owner must have done some sort of quick fix to it as can be seen in picture (the welding line).

 

But happily I've got a new one now from my own parts car and it should last for a while after reinforcing it by weldint the tube in it. By the way I kind of swapped it in already :) So that means I have a subaru that can be driven on road once again ! :)

  • Like 1

Share this post


Link to post
Share on other sites

I gutted the inside of my car to the point that I don't know if I will ever be able to put it back together again. It looks like Humpty Dumpty in there. on the bright side I did find a rats nest ontop of the heater core, so it needed to be done.

  • Like 1

Share this post


Link to post
Share on other sites

i got a GL 10 5speed duel-range 87  :wub:

Congrats!

I just acquired another one for the stable myself.

I bought something I've warned multitudes of others to run from.

86 XT Turbo 4WD LOADED 1 owner with 158k on the clock.

And damn near everything works :banana:

Its my DD for now and will be staying completely stock.

Damn those snails are fun. And I have joined the darkside officially now.

Don't disown me yet though! I'm still finishing my EA81 torque monster.

 

Twitch

 

PS: After the EA81's rolling, I'll see which car is faster :)

Share this post


Link to post
Share on other sites

Welcome to the wonderful world of flying door stops, Twitch! Pics? :popcorn:

The PandaWagon's tranny is being difficult lately so, I'm making my XT6 the daily driver while I decide what to do about a replacement tranny.

Share this post


Link to post
Share on other sites

Been doing a lot of meets in the Portland area with Ned since I got my license back, also gone through several sets of wheels trying to find out what I like best since I chose not to do the 5lug swap yet... Think the AA wheels in black will be my best bet, everyone seemed to like them, Ned is too tame looking now... but he hangs with the WRX/STIs with no issues... also gets to bark louder than most of them...

 

One from the Clackamas meet:

Carmeets_zps6ea195d5.jpg

 

As for what Ive done... Im more likely ABOUT to do a major overhaul on the front...

ordered Centric Discs for $8 a piece... those arrived and are ready for install

picked up a set of the ThermoQuiet brake pads

picking up 2 used but new front axles

picked up (4) 6207 2RS C3 bearings for $12/each to solve my wheel bearing issue

 

Gonna be tearing it down :D

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Maxima alternator.

IMG_20130615_113625_zpse8f3fb0f.jpg

Pretty straightforward installation. Took a bit of creativity to get the pulleys off though, without an impact.

Slightly disappointed, but at the same time impressed. I no longer have voltage drop when the bass hits through my system anymore, but I've noticed that my no load volt reading on the in dash voltmeter is lower now than it was with the original alt. Also, at idle with a full load (high beams, flashers, rear defroster, heater on full blast, interior lights on) my volt meter drops down to about 10 volts. My idle is high already, (1,000 rpm) so it's not that. Any ideas?

So like I said, both good and bad things.

IMG_20130615_113619_zps59e28b75.jpg

Share this post


Link to post
Share on other sites

Been doing a lot of meets in the Portland area with Ned since I got my license back, also gone through several sets of wheels trying to find out what I like best since I chose not to do the 5lug swap yet... Think the AA wheels in black will be my best bet, everyone seemed to like them, Ned is too tame looking now... but he hangs with the WRX/STIs with no issues... also gets to bark louder than most of them...

 

One from the Clackamas meet:

Carmeets_zps6ea195d5.jpg

 

I go to a meet every Wed night and a few more during the month.

This is from last Sat at the place I used to work at.

Outbackfotoshoot_zpsf1674a12.jpg

 

This is the Wed night meet.

SouthHillMallmeet_zps81a40a4a.jpg

I was the first one there and everyone parked the other way  :rolleyes:

Share this post


Link to post
Share on other sites

rear lsd and 4'' lift installed on crapwagon. tomorrow the fun part begins with the front xmember droppage. full 4'' drop, my axles look happier than theyve been for the last few years of 2'' lift and no drop. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×