Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

New Jeep bumper but can you see the problem


  • Please log in to reply
8 replies to this topic

#1 The Dude Abides

The Dude Abides

    WileE Coyote Super Genius

  • Members
  • 2,940 posts
  • West Des Moines, IA

Posted 25 April 2010 - 10:23 AM

So once again me and the daughter were car buddies again. This time on my brothers wrangler. IT wasnt to hard removing the old bumper and mounting this monstrosity on. But do you notice its leaning to the passanger side front. It has always leaned like this. If you notice the bumper is hooked up to the frame so the frame is strait. Just curious what ideas you have on what could cause this. And no because its a jeep isnt acceptable:lol:. I was thinking broken body mount, broken or weak spring. I know the spray bar bushings are destroyed on both sides but its only leaning on this side.

Couple Pics.
http://www.ultimates...&pictureid=2368
http://www.ultimates...&pictureid=2369

#2 T'subaru

T'subaru

    Subaru Fanatic!

  • Members
  • 443 posts
  • T'sunami Coast WA

Posted 25 April 2010 - 10:28 AM

suspension shouldnt have anything to do with it, its a frame - body issue..something has to be bent/twisted. Has a body lift been installed ?

#3 The Dude Abides

The Dude Abides

    WileE Coyote Super Genius

  • Members
  • 2,940 posts
  • West Des Moines, IA

Posted 25 April 2010 - 10:31 AM

It does have a salvage title and recieved a good smack on the driver side door area. But i dont see what that would half to do with the passanger side front leaning forward like that. Its seems about 1 1/2 inches lower then the driver side.

Oh and sorry no mods except wheels and a bumper at this point but he has owned it for the last 7 years. It has always leaned alittle but only i noticed. Not with this huge bumper on you can definately see something going on.

#4 T'subaru

T'subaru

    Subaru Fanatic!

  • Members
  • 443 posts
  • T'sunami Coast WA

Posted 25 April 2010 - 10:40 AM

It does have a salvage title and recieved a good smack on the driver side door area. But i dont see what that would half to do with the passanger side front leaning forward like that. Its seems about 1 1/2 inches lower then the driver side.

Oh and sorry no mods except wheels and a bumper at this point but he has owned it for the last 7 years. It has always leaned alittle but only i noticed. Not with this huge bumper on you can definately see something going on.


Salvage title and a hit...bet if you had on level concrete you could do some measuring floor to frame to body and find where its out of whack, that large bumber probly accentuates the problem.

#5 subaruguru

subaruguru

    Oldschool Cool

  • Members
  • 1,614 posts
  • Yakima Wa,

Posted 25 April 2010 - 10:48 AM

Probly a bad body mount.

Rob.

#6 The Dude Abides

The Dude Abides

    WileE Coyote Super Genius

  • Members
  • 2,940 posts
  • West Des Moines, IA

Posted 25 April 2010 - 12:02 PM

See rob thats what i was thinking. But when you rock it from side to side the pass side feels squishy. I looked underneath but couldnt find anything obvious.

#7 subaruguru

subaruguru

    Oldschool Cool

  • Members
  • 1,614 posts
  • Yakima Wa,

Posted 25 April 2010 - 12:15 PM

might be the mount broke through the body? or the squish you feel is a bum mount not physicly broken but worn down.

Rob.

#8 The Dude Abides

The Dude Abides

    WileE Coyote Super Genius

  • Members
  • 2,940 posts
  • West Des Moines, IA

Posted 25 April 2010 - 02:06 PM

so worn down it busted through. I know its over 10 years old but it had 30k on it when he bought it and it only has 90 now. He hasnt driven it much in the last 5 years, hence the dust.

#9 subaruguru

subaruguru

    Oldschool Cool

  • Members
  • 1,614 posts
  • Yakima Wa,

Posted 25 April 2010 - 04:28 PM

hmm well there are once in a life time problems we drive subarus you should know this lol.

Rob.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users