Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2001 Legacy GT limited


  • Please log in to reply
No replies to this topic

#1 gessner17

gessner17

    New User

  • Members
  • Pip
  • 8 posts
  • Iowa

Posted 12 April 2004 - 12:04 PM

Hey everyone, I'm a bit new to this forum, I have always owned older subaru's, mostly 2.2's. This is my first 2.5 and I am reading a lot of potentional problems with them. I have about 56k miles on mine, I am wondering if there is a forum with a list of potential probs to look for or if anyone could help me out on what to look for. I have and pretty much have always had a fairly heavy knock in my engine for the first 10 or so min when I take off for work, it doen'st completely go away, but gets quiet. That is the main thing I have been worried about, I have taken it to the dealer many times, they replaced the timing belt tensioner onece and now they say it is normal, it just seems way too loud. I also noticed last year when I had about 40k miles on it a strong radiator fluid smell and now have read about the leak prob. It went away after a few weeks, I couldnt' find any leakage anywhere. I am also wondering about what maintnance should be done. My 2.2 hardly ever needed any.
Any help is appreciated,
Matt




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users