Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

My parking lights won't turn on!!! 90 Legacy


  • Please log in to reply
1 reply to this topic

#1 subieman

subieman

    1000+ Super USER!

  • Members
  • 1,422 posts
  • Sparks, NV

Posted 15 April 2004 - 12:35 AM

My parking lights and horn do not work on my 90 Legacy Sedan. This is a project car I am fixing up to give to my girlfriend. It sat for about a year and a half. I’m thinking maybe mice chewed threw some wiring somewhere? The head lights work and so do the dash lights. When I turn the headlight switch on or push the horn I can hear the relays clicking… but no sound or lights. When I flip on the parking light switch on the steering conceal still nothing. All the fuses are good. Does anyone have a schematic or something I can look at??? Any advice would help out.

Thanks!

#2 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 15 April 2004 - 01:05 AM

Check the ground connections at the lights and horn.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users