Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

99 Forester - Speedometer issue... 1 problem or 2?


  • Please log in to reply
1 reply to this topic

#1 knelson

knelson

    USMB Regular

  • Members
  • PipPipPip
  • 36 posts

Posted 14 July 2004 - 03:55 PM

Newbie here with a problem... perhaps 2.

99 Forester with LCD odometer, no cruise control.

Problem 1: On two occassions, a month or so apart, the speedometer needle has stuck at 42mph when merging on to the freeway. When moving at 65mph, needle still says 42mph. When I go below 42, the needle comes back to life. When cruising along at 65mph I hit a little bump in the road and the needle comes back to life, and all is well in my little world again. All the while, the LCD odometer is clicking away the miles just fine.

Question 1 - To me, this seems like a mechanical issue with the speedometer head, but am seeking the collective wisdom of others to see if they've had this issue.

Problem 2: While watching the speedometer like a hawk because of "Problem 1" I notice that the speedometer needle occassionaly jumps around erratically within a 10mph window. For example... I'm cruising steady at 65mph, but the needle will jump from 68 to 62 to 65 to 60... in really quick movements - not gradually.

Question 2 - Is this related to Problem #1? (My opinion is NO since it seems electrical in nature.) I'm thinking I've got two different gremlins lurking here, but again am open to others' advice before I start getting dirty over it.

Thanks in advance for any input,
Kurt

#2 georgeinmd

georgeinmd

    USMB Regular

  • Members
  • PipPipPip
  • 35 posts
  • MD

Posted 15 July 2004 - 08:18 AM

Kurt -- well, I don't have an answer, but I have the identical car (but with cruise control) and the identical problem -- 42 mph, ten mph range, everything exactly the same. Smacking the top of the dash gets it operating properly for a while. Seems to be worse in damp weather. I, too, would welcome any insights. Thanx -- George




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users