Jump to content

Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse

- - - - -

Throttle Position Sensor.. Please Help

  • Please log in to reply
8 replies to this topic

#1 Guest_94LegacyL_*

  • Guests

Posted 25 June 2002 - 01:20 PM


This is my first time posting but I have a question, although it might be a dumb one. Today I was cleaning my engine bay, I took off the dust cover, which is in the middle and has MPFI and etc on it. Then I realized how dirty it was. I saw the TP Sensor and it was covered with dirt. I removed the screws, and took off the sensor. I only used a clean rag and no chemicals. Then I lined up the white marks which were there before, plugged everything back in and the CEL came on. I pulled the codes and it was the TP Sensor. I tried moving it barely in every direction but to no avail. I havent tried testing the voltage because I dont have a tester but does anyone have any suggestions?


#2 Guest_Legacy777_*

  • Guests

Posted 25 June 2002 - 01:47 PM

Shouldn't have pulled that guy off without knowing exactly where to line it up.

I'm assuming you have a 94 Legacy L......correct?

To fix it, you will need a multimeter and a feeler gauge, one that has 0.028" and 0.035"

The first gen legacies had the throttle on/off switch in the TPS. So that is the key one to get adjusted properly.

I've got a pic I scanned from the FSM about how to adjust and set the sensor.....but I can't seem to find it at the moment. I may have posted it......but since the search engine still sucks I'll have to find it when i get home.

#3 Guest_Legacy777_*

  • Guests

Posted 25 June 2002 - 01:52 PM


found the scans


The main thing you want to look at is on the second image, in the bottom right hand corner. It talks about setting the TPS so that the idle switch is positioned properly.

#4 Guest_94LegacyL_*

  • Guests

Posted 25 June 2002 - 02:33 PM


Thanks for the help.. I saw some testing equipment up at Lowes for a alright price. I will use that chart to test the lines and thanks again..


#5 Guest_megell_*

  • Guests

Posted 25 June 2002 - 03:04 PM

Don't forget to clear the codes from the ECU when done...Megell

#6 Guest_Legacy777_*

  • Guests

Posted 25 June 2002 - 03:54 PM

All you really need to do is use this diagram

Posted Image

Make sure you use the bottom idle stop screw like in the picture, not the top one.

#7 Guest_Scoobius Maximus_*

Guest_Scoobius Maximus_*
  • Guests

Posted 27 June 2002 - 01:34 AM

I have adjusted the throttle screw. It did nothing. Why does Subaru always say do not adjust?? What happens when you do? I have, and everything is still okay! What does this mean??




#8 Guest_Legacy777_*

  • Guests

Posted 27 June 2002 - 10:03 AM

what have you adjusted?

There are two throttle stop screws. One "can" be adjusted, that's the one up top, the one at the bottom where the pic says to put the feeler gauge in.....do not touch that screw. Really you shouldn't have messed with the top one either......

You gotta adjust the TPS according to those instructions. If you can not do this, you need to take it to someone that can.

#9 Guest_Legacy777_*

  • Guests

Posted 08 July 2002 - 06:35 AM

I'm movin this to the archives tomorrow unless anyone has any other issues.....

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users