Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1995, temp gauge fluctuates, P0125, coolant fluid leaks


  • Please log in to reply
2 replies to this topic

#1 linh4444

linh4444

    New User

  • Members
  • Pip
  • 2 posts
  • Southern Maryland

Posted 23 November 2004 - 01:50 PM

Legacy, 81K. The engine coolant leaks for months. Since yesterday, the temp gauge fluctuates between normal and high. This morning the engine check light was on and code shows “P0125 Clsd Loop Fuel Ctrl Insufficient Coolant Temp”. Any suggestions would be greatly appreciated.

#2 ferret

ferret

    Subaru Nut

  • Members
  • 669 posts
  • Northern NJ

Posted 23 November 2004 - 02:20 PM

P0125, from the Service manual it states that the engine is driven and detecting load. After a specific time, as determined by the temp, the coolant does not reach operating temperature. Could be defective coolant sensor or thermostat stuck open. That's for starters, after that you get into ECM and wiring continuity checks.

#3 linh4444

linh4444

    New User

  • Members
  • Pip
  • 2 posts
  • Southern Maryland

Posted 23 November 2004 - 10:27 PM

Thanks for the info.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users