Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

95 Legacy throwing a "P0101" with a "P0120"


  • Please log in to reply
2 replies to this topic

#1 DaveTV

DaveTV

    USMB Regular

  • Members
  • PipPipPip
  • 47 posts
  • Boston, MA

Posted 29 June 2006 - 02:26 PM

Hi gang - my 95 2.2 check engine light went on - checked codes, a P0101 (Mass air flow sensor circuit range/performance problem (high input)) combined with a P0120(P0120 Throttle/Pedal Position Sensor/Switch A Circuit Malfunction )
-reset them, all is good for the moment - no performance issues or trouble are apparent. Hmmm - anyone experience this? THX:)

#2 sammydafish

sammydafish

    New User

  • Members
  • PipPip
  • 24 posts
  • Woodstock

Posted 30 June 2006 - 07:46 AM

did your battery die and you have to jump start it?

#3 DaveTV

DaveTV

    USMB Regular

  • Members
  • PipPipPip
  • 47 posts
  • Boston, MA

Posted 30 June 2006 - 08:47 AM

Nope. That would be related to those codes..?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users