Jump to content

Search the Community

Showing results for tags 'code 340 after engine swap'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome to the USMB!
    • Meet n' Greet. Your USMB Welcome Center
    • Members Rides
  • Older Generations of Subaru's 1960-1994 Except Legacy and Impreza
    • Historic Subaru Forum: 50's thru 70's
    • Old Gen.: 80's GL/DL/XT/Loyales...
  • Newer Generations of Subaru discussion
    • 1990 to Present Legacy, Impreza, Outback, Forester, Baja, WRX&WrxSTI, SVX
    • BRZ and its Sister the Scion FRS/Toyota GT86
    • Crosstrek "XV"
  • Marketplace
    • Ultimate Subaru Store
    • Products for your Subaru
  • Upgrading and Racing Discussion
    • Performance Tech Forums
    • Subaru Modifications
    • Subaru MotorSports
  • Ultimate Subaru Repair Manual-The Knowledge Base of USMB. Complied posts and writeups to common problems and projects.
    • Submit a Tip or Mod to the USRM
    • Product Links and References
    • The old Ultimate Subaru Repair Manual
    • Engine
    • Engine Electrical
    • Transmission, Axle, and Brakes
    • Heating and Cooling systems
    • Body Exterior
    • Interior / Body Electrical
    • Stereo tips and tricks
    • Offroad Modifications
    • Suspension and Steering
  • Off Topic Areas
    • Shop Talk
    • Alternative Vehicles (non soob)

Product Groups

  • Member Accounts
  • Ultimate Subaru Decals
  • Subaru Parts
    • Weber Carbs and Parts
    • Used Subaru Parts

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Occupation


Ezboard Name


Referral


Biography


Vehicles

Found 1 result

  1. DavidHenry

    EJ25 2000 subaru engine swap issues.

    My 2000 Subaru outback engine locked up at 2:00 in the morning at 75 MPH going south on I-35 close to Dallas, Texas. All four wheels stopped turning...I had the clutch in within seconds but not before I nearly had a heart attack. Lucky I had a manual transmission. I brought the car home to San Antonio on a trailer. In the next few weeks I found another EJ25 engine at a local Pick and Pull that was in a 2001 Legacy sedan with an automatic transmission. Upon taking the engine home I removed the oil pan and heads and checked and cleaned everything. Replacing seals and timing belt, spark plugs, spark plug wires, head gaskets, and clutch. . I used my original fly wheel and intake manifold and all engine wiring. When I started it I had a bad miss. #3 was not firing even though it had plenty of spark and compression. And it was sucking fuel. I had to keep it ABOVE 2000 rpm to keep it running well enough to go around the block. I spent several days testing everything. It had an engine code of 340 and 341. Cam shaft sensor error so I at first thought I had made a mistake in the valve timing when I changed the belt. But after I double checked it I could not find a problem. I changed the sensor, made no difference. I checked the circuit for continuity. All was ok in the wiring, I checked and electro cleaned the wiring harness connectors. Still no improvement. Finely I took it to a well respected speed shop that is here in the city for a diagnostic evaluation as half of the cars they modify are Subaru’s. After half a day driving the tech crazy they gave up and suggested I must have mechanical problems in the left head #3 and 4... I took it home and started studying everything I could find on the web and talking to every Subaru Tech I could find...and then I heard a story about someone else who had this problem...Seems that Subaru uses a different cam sprocket for the cars with manual transmissions then they do for ones with automatic transmissions. Different number and position of the magnets embedded in the back of the sprocket. I removed the one from my old engine and it had two magnets about 90 degrees apart. I removed the one from this replacement engine that had previously been in the car with the automatic transmission and it had seven! I changed the sprocket and replaced the timing belt and the engine started and ran on all cylinders and stopped guzzling fuel. Ran smooth and sweet. The computer, Engine Control Unit (ECU) for the Subaru with the manual transmission is programmed differently than the one for the automatic transmission. I had read many posts about engine swaps but no one in any of these posts have mentioned this very important piece of information. And the timing sprocket on the crankshaft is different also. The one for the manual transmission has many teeth while the one for the automatic has only six. So any of you who are contemplating swapping engines take note and check your driver’s side cam sprocket and your crankshaft sprocket before you spend a week and a lot of money chasing this problem.
×