Jump to content
Ultimate Subaru Message Board

Recommended Posts

Excellent site!! Hopefully, someone can help me on my a situation I have with a 99 Legacy coil. 2.2 motor. 89K. A/T New plugs. The car had a miss and stutter and a check engine light code that AutoZone scanned and coded as a bad "cat". Rev th motor gets you a flashing ch light. Was able to determine that coil has NO fire for #1 plug. 2,3,4 fire nicely. Did the usual swapping of coil, wires with no change. The more I played with the coil/wire swap the worse it got. Went from an occasional miss to total loss of #1 fire. The lady I am doing the work for isn't rich and fears that the dealer will just start throwing expensive parts at it. Any suggestions on where I should start in finding the demons? Appreciate any help.

Feel free to e-mail me in order to quicken solution. Vehicle is mail delivery and can't sit idle.

Thanks!! Dave

Share this post


Link to post
Share on other sites

As I understand things, each coil fires two cylinders. If a "coil" was bad, I would think you'd have a problem with two cylinders not firing.

This would make me suspect the plugs or wires. When you swapped wires, did the problem stay with cylinder 1 or change to another?

You may want to go out tonight when it's dark with a spray mister and see if there is any leakage from a cracked coil pack or bad wire.

Just a thought.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×