Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

turbo light


  • Please log in to reply
2 replies to this topic

#1 johnw

johnw

    Member

  • Members
  • PipPip
  • 24 posts
  • sandy,oregon

Posted 17 October 2013 - 04:48 PM

on my 86 rx the turbo light is not comming on does that mean im not getting any boost from it.. and what do i do if im not 



#2 WoodsWagon

WoodsWagon

    Formerly 91Loyale

  • Members
  • 3,948 posts
  • NH

Posted 17 October 2013 - 10:44 PM

Light could have burned out, the pressure switch on the passenger side strut tower behind the air filter box could have died or the vacuum hose hooked to it could have broken.

 

Or you could have a big exhaust leak between the engine and the turbo.



#3 turboloyale

turboloyale

    Member

  • Members
  • PipPip
  • 18 posts
  • Deer Park, Washington

Posted 18 October 2013 - 07:40 PM

I have a 90 Turbo Loyale, my light hasent come on either but I can feel it spool up when it gets to about 2400rpms or so, or if I stomp on the gas the power light will come on and it spools up and away it goes.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users