Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Fuel pump relay stays energized


  • Please log in to reply
4 replies to this topic

#1 Carl B.

Carl B.

    USMB Regular

  • Silver Subscribers
  • PipPipPip
  • 116 posts
  • Colorado

Posted 31 March 2014 - 08:14 AM

I swapped an ej251 into my loyale.  Its running fine but not shutting off with the key.

The fuel pump relay is staying energized when I turn the key off and remove it.  Can anyone help me figure this out, please.

 

I have my switched power connections hooked into the EA where the old fuel pump relay got power.

 

I have it wired as follows:

 

Fuel pump relay

terminal 1 -switched power, green/red wire

              2 -hot,  black/red wire

              3 - to ECM untouched, green/black wire

              4 - to pump, black/red wire

 

Main relay

1- ground, black

2 - untouched, green/black

3 - switched power, yellow/blue

4 - switched power, yellow/red

5 - hot, black/red

6 - hot, black/red

 

 

 

 



#2 Gloyale

Gloyale

    It's a sickness

  • Members
  • 9,250 posts
  • Corvallis, OR PNW

Posted 31 March 2014 - 10:55 AM

I swapped an ej251 into my loyale.  Its running fine but not shutting off with the key.

The fuel pump relay is staying energized when I turn the key off and remove it.  Can anyone help me figure this out, please.

 

I have my switched power connections hooked into the EA where the old fuel pump relay got power.

 

I have it wired as follows:

 

Fuel pump relay

terminal 1 -switched power, green/red wire

              2 -hot,  black/red wire

              3 - to ECM untouched, green/black wire

              4 - to pump, black/red wire

 

Main relay

1- ground, black

2 - untouched, green/black

3 - switched power, yellow/blue

4 - switched power, yellow/red

5 - hot, black/red

6 - hot, black/red

 

So....on the fuel pump relay....The Green/Red wire....are you providing that with switched power????.....I'm pretty sure it should get powered on by the ECU.....

 

And the main relay.......When you say 3+4 are switched power....are you saying you put power to thoses wires??  Or that those are the ones that get powered on when you turn the key?

 

IIRC.....I think you on;y need to provide a switched power to the ECU...and it should turn on the FP relay.

 

What year model is your harness from???



#3 Carl B.

Carl B.

    USMB Regular

  • Silver Subscribers
  • PipPipPip
  • 116 posts
  • Colorado

Posted 31 March 2014 - 04:54 PM

Yes I am providing switched power to the green red wire on fuel relay, also to 3 & 4, yellow wires, on main relay.
harness is from 01 impreza 5spd with 3 plug ecu. Which wire is sitched power to ecu?
I went down to the local subaru shop and color codes for wiring are same for all the 99-04 ej251 that I have looked at.

#4 Gloyale

Gloyale

    It's a sickness

  • Members
  • 9,250 posts
  • Corvallis, OR PNW

Posted 31 March 2014 - 06:17 PM

Yes I am providing switched power to the green red wire on fuel relay, also to 3 & 4, yellow wires, on main relay.
harness is from 01 impreza 5spd with 3 plug ecu. Which wire is sitched power to ecu?
I went down to the local subaru shop and color codes for wiring are same for all the 99-04 ej251 that I have looked at.

 

I was somewhat confused.....It is the Main relay, not the Fuel relay that is given 12v+ by the ECU.    But in red above lay the problem.

 

 

 

Those wires BECOME energized and switch to ON by the relay.......they are the Load sides of a Double pole relay. (they supply all the solenoids,IAC,Maf,Coil transistor in the engine bay)  The Green/Black is the 12v+ side of the relay's coil and of course the ground is ground.  The Green/Black wire is supplied power by the ECU when the ECU is given power. 

 

 Powering on your EJ's harness should be done at pin c10 of the ECU connector.....Which should be a Green/red wire.   You are indeed correct that the Green/red wire at the Fuel pump relay should get Ig. 12v+..........This wire should connect back to the ECU at pin c10.  Somewhere in the strip down they got chopped apart......but should connected.


Edited by Gloyale, 31 March 2014 - 06:21 PM.


#5 Carl B.

Carl B.

    USMB Regular

  • Silver Subscribers
  • PipPipPip
  • 116 posts
  • Colorado

Posted 31 March 2014 - 06:36 PM

And the main relay.......When you say 3+4 are switched power....are you saying you put power to thoses wires?? 

 

When you said that I knew that must have been my problem.

 

That was exactly it.

 

Thanks so much!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users