Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1995 LEGACY Transmission Trouble


  • Please log in to reply
2 replies to this topic

#1 SATANS_CABANA_BOY

SATANS_CABANA_BOY

    New User

  • Members
  • Pip
  • 6 posts
  • eugene

Posted 02 July 2004 - 02:08 PM

I’m looking for any words of wisdom on what needs to be done to get this great car up and running again.

1995 LEGACY WAGON, 5-SPEED 218,000 MILES

Well, here is my problem. When the light turned green I pushed down on the clutch pedal and I could not put it into ANY gear.

Shut the engine off, I can put it into gear, start the engine to hear a loud grinding noise, shut it down and tow it home.

#2 cookie

cookie

    Elite Master of the Subaru

  • Members
  • 3,058 posts
  • SFO

Posted 02 July 2004 - 02:44 PM

that is one failure mode. Did it slip before? How many miles on the clutch?

#3 SATANS_CABANA_BOY

SATANS_CABANA_BOY

    New User

  • Members
  • Pip
  • 6 posts
  • eugene

Posted 03 July 2004 - 10:00 AM

In the years that I have owned this car I never replaced the clutch, and at the time of the break down the clutch felt very strong. I forget to mention earlier that I could put it into 4th gear but it would pop out when I let up on the clutch pedal.



Christian

that is one failure mode. Did it slip before? How many miles on the clutch?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users