Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

coolant temperature sensor


  • Please log in to reply
3 replies to this topic

#1 96legacy

96legacy

    New User

  • Members
  • Pip
  • 2 posts
  • Waco

Posted 25 January 2005 - 02:04 PM

My check engine light came on and a scan revealed a bad coolant temperature sensor. How hard could that be to replace, right? Where is the blasted thing located on my 96 Legacy Outback with a 2.2, 5 speed? I'm kind of new at this, so thanks for your help.

#2 1990legacy

1990legacy

    USMB Regular

  • Members
  • PipPipPip
  • 74 posts
  • Harrisonburg

Posted 25 January 2005 - 02:10 PM

My check engine light came on and a scan revealed a bad coolant temperature sensor. How hard could that be to replace, right? Where is the blasted thing located on my 96 Legacy Outback with a 2.2, 5 speed? I'm kind of new at this, so thanks for your help.


Well, I just did the one on my car, and since it would appear you have the same engine, the temp sensor on your car should be located below and to the left of your alternator, which has to come out to get at the sensor. But really, its a fairly simple task, just remember the order in which you took things out. And the sensor should run you like $7 or so at a parts store.

#3 Bill90Loyale

Bill90Loyale

    Subaru Fanatic!

  • Members
  • 423 posts

Posted 25 January 2005 - 02:11 PM

The sensor is to the left of the coil pack and tucked way down underneath some PCV hoses and two big wiring harnesses. Hard to find the first time. Search the forum. There are pictures out there. A bad CTS should cause you to be having hard starting (turns over, but won't fire up the way it should). About $30.

#4 96legacy

96legacy

    New User

  • Members
  • Pip
  • 2 posts
  • Waco

Posted 26 January 2005 - 06:45 PM

Thanks for your help. I found it, replaced it and voila! No light.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users