Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Brat wont start


  • Please log in to reply
3 replies to this topic

#1 cpiunno

cpiunno

    New User

  • Members
  • PipPip
  • 19 posts
  • Denver, Co.

Posted 12 September 2003 - 03:50 PM

My Brat wont turn over at all. I am able to jumpstart it so I went ahead and bought a new battery. I drove it around for 15 minutes with the new battery in and it still wont start. Like the battery isn't charging at all. The alternator is measuring 14 volts. The alternator was replaced 2 months ago and has been working for 2 months. I checked all fuses are good. What else could affect the charging system, other than thsi new alternator being bad?

#2 ShawnW

ShawnW

    Subaru Master Technician

  • Administrator
  • 12,931 posts
  • Denver, Colorado

Posted 12 September 2003 - 04:06 PM

What year is it?

Is it the turbo fuel injected one or the carb?

"Won't start" is vague....will it crank and crank but never fire, or will the starter motor not turn....? More info would lead to a solution.

#3 rallyruss

rallyruss

    Subaru Master

  • Members
  • 1,653 posts
  • San Jose CA

Posted 12 September 2003 - 05:02 PM

if you have a click but no start. it can be a bad starter. the contacts get worn out after a while. jump starting could have given it the extra juice to close the contacts. gently beat on the starter with a piece of wood while someone holds it in the crank position. if it starts its a starter problem. there are more things to chech but thats the easyest.

good luck

#4 cpiunno

cpiunno

    New User

  • Members
  • PipPip
  • 19 posts
  • Denver, Co.

Posted 12 September 2003 - 08:27 PM

Thanks for the help guys. The starter suggestion reminded me of a problem I had with my Eclipse a while back where it wouldn't turn over at all. I made the assumption that if the terminals were going bad that the car would be hard to start, not that it wouldnt turn over at all. I went ahead and replaced the battery terminals and its working good now. I'm always overlooking the little stuff.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users