Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

too high cold idle?


  • Please log in to reply
2 replies to this topic

#1 Midwst

Midwst

    Subaru Fanatic!

  • Members
  • 373 posts
  • Cedar Rapids

Posted 22 August 2005 - 11:30 AM

When I start my 96 legacy cold, the idle holds at 1500 rpm for a little bit, unless I tap the gas pedal, but if I tap the gas pedal too soon, sometimes it doesn't drop down much. I understand the elevated rpm for cold start is normal, but 1500 is much higher than I have noticed on other cars...including other subarus. Is there anyway to bring it down...or could there be a problem with one of the sensors? Thanks.

#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,643 posts
  • Houston, Tx

Posted 22 August 2005 - 12:17 PM

1500 rpm is normal for cold idle. You're car is fine.

#3 Setright

Setright

    Elite Master of the Subaru

  • Members
  • 3,176 posts
  • Denmark

Posted 22 August 2005 - 02:54 PM

Yep, sounds normal.

But it does seem to really hold onto the revs when cold. Tap the gas and it jumps up but takes ages to get back down.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users