Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Help, Brake lights not working Run Lights stay on!


  • Please log in to reply
3 replies to this topic

#1 Escapegoat

Escapegoat

    New User

  • Members
  • PipPip
  • 11 posts
  • Big Rapids, MI

Posted 29 September 2005 - 08:22 PM

I just changed the battery terminals yesterday. I turn my car off and the running rear lights stay on and the brake light will not work.

Any ideas?

95 Impreza 1.8 AWD

#2 Escapegoat

Escapegoat

    New User

  • Members
  • PipPip
  • 11 posts
  • Big Rapids, MI

Posted 29 September 2005 - 08:45 PM

nevermind....lol...I see its a common baffle thread....duhhhhh.

#3 mtsmiths

mtsmiths

    Subaru Master

  • Members
  • 1,640 posts
  • Kailua-Kona, Hawaii

Posted 29 September 2005 - 11:12 PM

nevermind....lol...I see its a common baffle thread....duhhhhh.


Hee, hee, hee, another 'Subaru Virgin' deflowered.

#4 beetreesubie

beetreesubie

    User Awaiting Email Confirmation

  • Members
  • PipPipPip
  • 92 posts
  • 28753

Posted 15 January 2006 - 12:46 AM

one word fuse!!!!:grin:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users