Jump to content

joverv83

Members
  • Content count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About joverv83

  • Rank
    Newbie

Profile Information

  • Location
    Canada
  • Referral
    Google Search
  • Biography
    love to play outdoors - need a car that can carry gear, bikes, boats, dogs as well as me and the lady! forester is perfect, but it's far from perfect....
  • Vehicles
    2003 Forester XS
  1. Many thanks. You are not the first MR_Loyale to ention the coolant temp sensor, so I will pass that on! Will update.
  2. Hoping someone has had a similar issue or someone could give some direction for this noob... I have a 2003 Forester XS 2.5, 140xxx km (87000 miles). Timing belt, heads and cover gaskets done @ 139xxx km with no CELs. Especially when the car is warm, it will start extremely rough. Heavy knocking, car shuttering and eventually does not fire (either I stop trying for fear of the engine ripping right off the engine mounts or it just won't start). After two or three miserably failed attempts at starting, she eventually starts and runs with no issues other than slightly worse gas mileage than before this problem started. So... To fix this issue I first started with this website and found a couple suggestions - so I changed spark wires and had the ignition coil tested. Even tried replacing the IC to see if it changed anything. It did not. Next step was take it to a local shop. They tested fuel pressure, air intake and filter...no luck. So, reluctantly, I took it to the local Subaru dealer. My car has been there for over a month now and still NO idea what is wrong with it. They have checked "everything" starting with the starter to wiring, crank and cam sensors, checked whatever the name of the part the the cam sensor reads, performed exorcisms, washed it with holy water.... Now they are currently replacing the computer. To be fair, the mechanics have been great with me, but I'm still BAFFLED how I can spend $1000 on a trained, licensed Subaru mechanic and they still have NO idea what is going on. They know what ISN'T causing the issue, but that doesn't help me. So, a couple questions. Any advice or pointers toward what this could be are so welcomed and much appreciated. I'm happy to provide any info you need to try to get a better picture of what's going on. Also, I'm wondering if there's anything I can do to fight a repair bill that, in the end, hasn't told me anything at all. Should a dealer be pressured into helping with this bill? Again - they have been very fair trying to save me as much money as possible, but $1000 is $1000. Thanks so much everyone!
×