Jump to content

Baka.sti

Members
  • Content count

    12
  • Joined

  • Last visited

Community Reputation

1 Neutral

About Baka.sti

  • Rank
    Member

Profile Information

  • Location
    701 South Shawnee drive
  • Referral
    I found this page trying to fix my car lol
  • Biography
    I have a 2011 Subaru Sti Hatchback soon to be 450 whp
  • Vehicles
    2011 Subaru Sti

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello everyone I changed the spark plugs I started the car and it no longer had the check engine light on and idles fine but I will not be driving my Subaru until my access port gets here
  2. Okay thanks very much GD I just order my access port and I pulled the plugs today and I don’t think they have even been switched in their whole existence of the car they were black on the tips like carbon build up idk if that’s what it is but that was the condition I didn’t start the car as it got to late but will start up tomorrow morning
  3. Okay sounds good well I’m going to pull the plugs tomorrow they came in early so I will see if it is just the plug and if not I will asses from there but next to get is definitely the AP thanks GD I appreciate you and also would the AP also be beneficial since I’m pretty sure the previous owner removed or gutted the cat pipe so it’s loud or would I have to get a proper tune
  4. Honestly this is why I appreciate people like you because honestly I was going to buy an AOS just because of what people say on YouTube and how it helps the engine but I’m glad there are people like you that are knowledgeable with Subaru and their engines where is your shop located if you don’t mind me asking and the next thing I will get will be the Cobb access port and I appreciate you guys a lot for all the input and help/knowledge
  5. Yes sounds good but isn’t the AOS necessary since it helps prevent ring land failure but I will buy the access port first
  6. The car never felt out of power or would ever go into limp mode before this and it would idle rough for only a couple seconds then jump back into rhythm I have warranty on the car but I have oil in the car I checked all fluids there’s isn’t anything leaking they were all filled so I’m hoping it’s just the spark plug but when they arrive on Monday I’ll know for sure if it was just the spark plug or see the real problem I honestly don’t know if it had an accessory before but I’m planing to get one after a AOS
  7. Sounds good I’m actually going to swap out all plugs on Monday and check them all and I’m not sure what plugs are in right now or how old I bought this car from the dealer last month they said they had done a service on it and a check in the engine but I’ll check the plugs Monday I appreciate all your guy’s help
  8. My car is a 2011 Subaru Sti hatchback the only mods are a Cobb intake and a straight pipe both from previous owner I barley got the car a month ago from a dealer
  9. Hey guys I haven’t pulled the plugs yet but yes my car did go into limp mode and shut off but then turned on but would try and turn off but barley sputtered to stay on
  10. Thank you I appreciate it I will check the plugs tomorrow and I might be concerned or I honestly don’t know if this information is useful but before the check engine came on I would sometimes get a strong exhaust smell or I would get a rough idle but the car would then idle normally and would only happen probably once a week.
  11. Hello everyone I was wondering if I could have a helping hand so here is the story I was driving my Sti was waiting at a red light when the light turned green I accelerated once I reached about 20 mph the car seemed like it wasn’t giving me power and seemed like it was bogging and when trying to accelerate or go past around 20 mph it shut off completely I pulled over and my check engine came on I read it with a scanner and it said p0304 which is a misfire in cylinder 4 so would it be best to change the spark plugs first?
  12. Hello everyone I was wondering if I could have a helping hand so here is the story I was driving my Sti was waiting at a red light when the light turned green I accelerated once I reached about 20 mph the car seemed like it wasn’t giving me power and seemed like it was bogging and when trying to accelerate or go past around 20 mph it shut off completely I pulled over and my check engine came on I read it with a scanner and it said p0304 which is a misfire in cylinder 4 so would it be best to change the spark plugs first?
×