Jump to content
Ultimate Subaru Message Board
Sign in to follow this  
rrgrr

Heater blower failure

Recommended Posts

The 83 GL verticoupe is coming along-but I need Help! - been working on my cooling system trying to get my cooling fan/thermoswitch situ figured out, now my heater blower has quit working all at once. Removed the fan and hot wired it -it turns just fine, the fuse has power w/key,... I've been thru Alot of threads, and can't find any relay under the dash where they are described, just one for the headlights, and the wiper thingy. Near the coil I discovered 3 relay doohickeys, one of which is funky-that runs the AC fan -don't know about the others, but I think those are cruise, and something else with a weird plug.

Can some one help me find if there is a relay on this car?

-R

Share this post


Link to post
Share on other sites

Check the connector at the fan. The Green/white wire in the connector should have 12v w/ key on.

 

if it does, problem isn't the relay. problem would be in the reistor pack, mounted to the far front of the heater box, drivers side.....could be unplugged.....if it was just bad, you'd still have speed 4.

 

 

If it doesn't have 12v, then probably is the relay.

 

relay is up in the dash, drivers side.....look for the one with a fat white, and a kinda fat Green/white wire.

Share this post


Link to post
Share on other sites

Please, if someone could put up a pic of where the relay is -I swear there is nothing I can find -and where is this resistor coil thingy? is it all the way at the firewall? how to get it out?

I've got no power at the fan pigtail, and I don't see the four relays everyone refers to on the drivers side -I can post a picture if someone can point it out..:banghead:

Share this post


Link to post
Share on other sites

Sucker- thanks so much for coming thru for me! I was at a loss. Is that a Bently book?

I didn't cut power, so when I opened the fuse 'capsule' the thing had disintegrated -and the bit of wire bridged the hot to something else and quickly burned up the insulation all the way up to the big harness, -smoking while I pulled fuses and tried to get it free!!,:eek:

Anyway thanks again for your help :headbang:

-R

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×