Jump to content
Ultimate Subaru Message Board
84GLturbo

One more mystery wire

Recommended Posts

 This is the last wire that was chewed up by the killer mouse. It is thick black insulation coming out of the harness with a white plug attaching to a light green wire that is about 10" long where it was chewed. I have searched every diagram I can find and crawled all over the vehicle looking and cannot find where it attaches. It comes out of a harness under the spare tire holder, the fingers in the picture are on the starter for reference. Any help would be greatly appreciated. post-69491-0-21768500-1512166014_thumb.jpg

 I guess it would help if I added it's an 84 GL 4wd turbo.

Edited by 84GLturbo

Share this post


Link to post
Share on other sites

The one w/the black/white connector is the O2 sensor.

Mine has black wires on both sides.

Edited by naru

Share this post


Link to post
Share on other sites

 Thank you but here is the dumbass question... Where is the O2 sensor on this thing. The book shows it on the manifold on the pass side but after an hour of looking I can't find it anywhere without removing a bunch of shields. I have followed the exhaust from mid car to the downpipe and it disappears under a shield that looks like a pain to get to the bolts to remove it.

Share this post


Link to post
Share on other sites

Below the turbo and shields on the rear side.

Might have to look from the bottom to actually see it.

Changed mine once.No big drama.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×