Jump to content
Ultimate Subaru Message Board

Recommended Posts

Hi ALL again!

I did by that 2.5 GT Leagcy Wgn. It's got 123K miles on it. I just came back from MAss inspection. It FAILS the EGR test. Earlier that day I brought it to my mechanic, he reset the OBDII. It said it had an EGR problem. This car has sat around ALOT for 2 months before I bought it! Pine pitch and all! Anyhow, cleared the code, I drove around to do registration stuff, light came back on after about 25 miles or so!!! What to do?????

 

MANY thanks, Ted

Share this post


Link to post
Share on other sites

I have a 97 OB with an EGR issue that's been going on for a year. Hopefully, it will be resolved tomorrow. (Nothing major, it's just that the first failed item found wasn't the only failed item, and I've just been lazy about dealing with it.)

 

There are a few threads on here discussing EGR problems. It seems to be fairly common around the age and milage of your vehicle.

 

Commuter

Share this post


Link to post
Share on other sites
I have a 97 OB with an EGR issue that's been going on for a year. Hopefully, it will be resolved tomorrow. (Nothing major, it's just that the first failed item found wasn't the only failed item, and I've just been lazy about dealing with it.)

 

There are a few threads on here discussing EGR problems. It seems to be fairly common around the age and milage of your vehicle.

 

Commuter

Hi Mr. C,

 

I can't do a "EGR" search! It comes back with "too many replies"! I tried the word "emissions" I don;t get enough specific info! I still need help in this area!

Many thanks, STed

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×