Jump to content
Ultimate Subaru Message Board

Recommended Posts

Hello, nice site. I'll be here pretty often as I have a '91 Legacy with .25 million miles on it.

 

The turn signals as well as the hazzards just stay on when I try to use them. I'm guessing that my flasher relay is bad. I saw a picture of it at the parts store, but I can't seem to find it in my car. Can you help me?

 

Sh-

Share this post


Link to post
Share on other sites

According to Subaru, it's not a "flasher", it's a "Turn Signal and Hazard Unit". (love those engineers).

 

My manual says to remove the glove box and then the glove box frame.

Disconect the unit connector and remove three screws that hold it to some bracket. It's in there someplace next to the Illumination Control Unit.

 

Sorry I haven't done this repair so I can't vouch for the directions.

Doesn't look like the typical flasher can from the poor illustration.

Share this post


Link to post
Share on other sites

Thanks so much, you wouldn't believe how much I've had to search for that info. I'll be digging into my dash at the first daylight opportunity I have.

 

What brand of manual do you use? My chilton's book says nothing about a "Turn Signal and Hazard Unit".

 

Sh-

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×