Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Broken timing belt 90 loyale


  • Please log in to reply
4 replies to this topic

#1 CrankyAl

CrankyAl

    New User

  • Members
  • PipPipPip
  • 37 posts
  • Bend, Oregon

Posted 10 February 2013 - 10:18 PM

I replaced a broken timing belt on my wifes 90 Loyale Christmas day 2011. I installed new tensioners and idler pulley plus the belts...PMI I believe the name on the kit.

Today the belt broke again. The first time the idle pulley broke and the ball bearings went ballistice underneath the belt housing and shreaded the belt. Understandable. Todays broken belt and pullys

don't indicate what the cause is. Just a broken belt. The pullys are all ok, no excess loosness nor binding.

  So are there any recommendations for timing belt kits? I will try a different brand. I will change everything

again. Also last year I didn't change the H2O pump. I usually use AISIN pumps, but I always bought pumps for Loyales with Air Conditioning......this car does not have AC, I have read that the pumps can be different. Anyone know which pump to get. Long winded but almost done.

 

NO oil on belt that broke, no rocks or sticks, no water or any wetness at all. Just a bad belt??? 13months 10days old........less that 7,000miles on the belt.

OK, I'm done

 

 

 

 

 

 



#2 El Presidente

El Presidente

    Subaru Fanatic!

  • Members
  • 550 posts
  • Northgate/Seattle, WA

Posted 11 February 2013 - 12:09 AM

Probably just a bad belt. When it comes to belts, I only use Gates or OEM Subaru. You probably don't need new pulleys, but I'd leave the belt covers off and watch it run, you might be able to spot the problem while everything is turning. If you want to, you can throw the belt covers away..it makes inspections more frequent(anytime you pop the hood) and it makes changing belts a 10 min job. Only time it was ever a problem for me was when I was fording about 3' of water with an inch of ice on it. Ice got in the cogs and snapped my pass. side belt..luckily I disabled my clutch start switch so I was able to drive out on my starter. 

 

Josh



#3 TomRhere

TomRhere

    Certified BRAT nut!!!

  • Members
  • 4,005 posts
  • Hillsdale, Mi. USA

Posted 11 February 2013 - 04:55 AM

I agree with the Gate's or OEM for timing belts on any engine that runs them. Have had to many other brands of aftermarket belts fail.



#4 scoobiedubie

scoobiedubie

    USMB is life!

  • Members
  • 473 posts
  • Aloha, Oregon

Posted 11 February 2013 - 11:38 AM

There are two types of water pumps.  Long stem and short stem.  The short stem are for subarus with turbos.  The long stem are for everything else.  Doesn't matter what your other accessories are.



#5 CrankyAl

CrankyAl

    New User

  • Members
  • PipPipPip
  • 37 posts
  • Bend, Oregon

Posted 11 February 2013 - 01:49 PM

Scoobiedubie, Thank you very much for the water pump issue....Turbo...I knew there was a difference I just coudn't remember. I had

AC stuck in my mind as the difference. Thanks to everyone else for the belt info. I have seen a lot of timing belt parts recommended

and alot of the forum folks say that the ebay kits are just fine. PCI was the kit I installed.....also on my other Loyale, shudder!!

 

It seems Subaru stealership is the way to go on so many parts! To bad, GOOD third party parts would make someone very rich.

 

My folks live in Aloha....I go there when my Subie runs well enough to get me there and back home to Bend. :-)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users