Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1988 gl-10 turbo ?


  • Please log in to reply
6 replies to this topic

#1 67D100

67D100

    Newbie

  • Members
  • Pip
  • 3 posts
  • United States

Posted 09 June 2014 - 02:18 AM

Hello everyone! I owned a 1988 subaru DL wagon years ago and drove the snot outa it and i never let me down. Ive been looking for another one recently and came upon a 1988 GL-10 turbo wagon forsale.

 

I havnt gone to check it out just yet, but it just had 


Machined heads
New head gaskets
New fuel filter
New spark plugs
New spark plug wires
Replaced water pump
New thermostat
New coolant temp sensor
New 02 sensor

 

but the owner says it wont pull a rev??? 

 

Any ideas? I have years of knowledge and experience on cars and trucks, diesel and gas turbo and N/A im just wondering if this particular model of subaru has any notorious issues? if this is a common thing? and what i should look for first? 

 

BTW hes asking $1k obo for the car

 

Thanks 

Jason



#2 Scooner

Scooner

    New User

  • Members
  • 348 posts
  • Cheyenne, Wyoming

Posted 09 June 2014 - 07:57 AM

Can't pull a rev? Sounds like a snowboarding trick. Well since this car is a GL-10 it has a turbo unlike your regular GL you had before, which i'm sure you knew. Maybe the turbo has crapped out?

#3 MilesFox

MilesFox

    Catch this Fox!

  • Members
  • 10,435 posts
  • Madison/Milwaukee, WI

Posted 09 June 2014 - 07:57 AM

Likely ythe distributior timing is wrong, or the timing belts are installed wrong. If you get someone looking at it telling you there is no compression and tyou have bent valves on one side, the cam is upside down on one of the belts. Should be easy to fix, just make sure it is put together correctly.

 

These models are known to get hot or fail heads, but usually because they are 25 years old with corroded radiators, old hoses, old/low coolant. but by themselves are reliable if the cooling system is maintained, and run within stock parameters, boost, timing



#4 hush777

hush777

    More Subarus than Kids!

  • Members
  • 388 posts
  • Idaho

Posted 09 June 2014 - 09:02 AM

Possible exhaust restriction or bad intake flow would also be something the check out if everything else checks out ok.

 

Hush



#5 soobie_newbie67

soobie_newbie67

    Eat, Live, Breath Subaru

  • Members
  • 471 posts
  • Kennewick

Posted 09 June 2014 - 10:42 AM

Where's it at?

#6 rain_man_rich

rain_man_rich

    USMB Regular

  • Members
  • 137 posts
  • Grants Pass

Posted 09 June 2014 - 11:15 AM

major vac or intake leak



#7 67D100

67D100

    Newbie

  • Members
  • Pip
  • 3 posts
  • United States

Posted 09 June 2014 - 12:51 PM

Id like to go take a look at it soon and check things out myself, the cars is in Sacramento CA. I was thinking probably a vaccum leak or bad timing also. the car has 200k on it also. I was just curious if $1k obo is a decent deal? 

 

thanks






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users