Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Compatibility question--EA81 GL vs. DL


  • Please log in to reply
2 replies to this topic

#1 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 31 October 2004 - 05:21 PM

Looking to install an '82 dash and instrument cluster from a '82 GL Brat into an '82 DL Brat. Did the early Subes have the same wiring harness for these two models...that is, will the tach from the GL work in the DL without having to re-wire the DL recipient car? If anyone else has tried this before, I'm hoping to do this but don't want to expend the effort if it can't be made to work without a lot of grief.

#2 stngllhm

stngllhm

    Subaru Fanatic!

  • Members
  • 366 posts
  • Casper

Posted 31 October 2004 - 06:48 PM

not quite the same put the digital dash on my 84 gl went bad and i swaped it out with an analog from a 83 dl i had to swap the wiring harness under the dash out to do it magor pain. but it was the only way i could get a car and when your 16 and live out of town a car is important. ok ok back to the subject i belive if both are analog you should be ok. but something to keep in mind if one has a oil presure gauge and the other a light you need to swap out the sending unit as well. hope the info is helpful

#3 edrach

edrach

    RIP 6/28/14

  • Members
  • 12,326 posts
  • Bothell, WA

Posted 31 October 2004 - 08:16 PM

Thanks for the reply. Yes, I know about the oil sender vs. pressure switch syndrome. We ran into it when we installed the rebuilt engine from CCR. We hadn't told them it was a DL and it came with the sensor. Five minutes with them on the 'phone and everything was resolved. Great people there.

not quite the same put the digital dash on my 84 gl went bad and i swaped it out with an analog from a 83 dl i had to swap the wiring harness under the dash out to do it magor pain. but it was the only way i could get a car and when your 16 and live out of town a car is important. ok ok back to the subject i belive if both are analog you should be ok. but something to keep in mind if one has a oil presure gauge and the other a light you need to swap out the sending unit as well. hope the info is helpful






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users