Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

1995 Impreza stalling


  • Please log in to reply
2 replies to this topic

#1 Rooba Doo

Rooba Doo

    New User

  • Members
  • Pip
  • 8 posts
  • Short Gap

Posted 17 February 2005 - 12:43 AM

I just bought a 95' Rooba Doo Impreza from a buddy of mine. The engine starts, idles, and runs perfect but when driving down the road it is like someone reaches over and turns the key off and throws it out the window. I then usaully pull off to the side of the road or push in the clutch (5-speed) and restart. It always starts right back up, sometimes it will spit sputter and carry on for a while then it will run fine again. The check engine light comes on ONLY when it is spiting and sputtering then goes off when the engine clears up. The guy i bought it from said he has had this problem for a while. He had crank angel sensor, cam angel sensor, coil and ignitor,plugs and wires and fuel filter replaced and still.... stalls:banghead: . I was thinking Oxygen sensor. A friend of mine had a Jeep wrangler that would spit sputter and stall, he changed the O2 sensor and it was cured:brow: . What do you guys think any help would be awesome. The car is a 95' Impreza, AWD, 5-speed, 160,000 miles Thanks

#2 Gnuman

Gnuman

    1000+ Super USER!

  • Members
  • 1,399 posts
  • Richmond, CA

Posted 17 February 2005 - 12:57 AM

I just bought a 95' Rooba Doo Impreza from a buddy of mine. The engine starts, idles, and runs perfect but when driving down the road it is like someone reaches over and turns the key off and throws it out the window. I then usaully pull off to the side of the road or push in the clutch (5-speed) and restart. It always starts right back up, sometimes it will spit sputter and carry on for a while then it will run fine again. The check engine light comes on ONLY when it is spiting and sputtering then goes off when the engine clears up. The guy i bought it from said he has had this problem for a while. He had crank angel sensor, cam angel sensor, coil and ignitor,plugs and wires and fuel filter replaced and still.... stalls:banghead: . I was thinking Oxygen sensor. A friend of mine had a Jeep wrangler that would spit sputter and stall, he changed the O2 sensor and it was cured:brow: . What do you guys think any help would be awesome. The car is a 95' Impreza, AWD, 5-speed, 160,000 miles Thanks


What codes does it throw? The ECU should store the codes until you clear them. a '95 should be OBD II.

#3 Rooba Doo

Rooba Doo

    New User

  • Members
  • Pip
  • 8 posts
  • Short Gap

Posted 17 February 2005 - 01:09 AM

What codes does it throw? The ECU should store the codes until you clear them. a '95 should be OBD II.

------------------------------------------------------------------------------------------------------Im not sure about the codes I just bought the car yesterday, really cheap i might add, thought it might be a quik fix. I wasnt sure on the ODB II (untill you cleared that up for me) ppl I have talked to say it was prob ODB I, it being a 95 and all Even I thought 96 was the first year for ODB II i guess subaru beat everybody to the punch. Can you or anyone else tell if and how i can get the codes out myself? thanks P.S. thinking it might be the O2 sensor, am I leaning toward the right track?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users