Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Tuning Up the Coupe


  • Please log in to reply
2 replies to this topic

#1 Bucky92

Bucky92

    Drive Fast, Take Chances

  • Members
  • 3,664 posts
  • New Milford

Posted 13 May 2005 - 06:30 PM

OK..So this weekend I am planning on giving Lucky a tune-up. New Plugs,wires,cap,rotor, going to try and fix some of the mousey damage to some wires.

If this doesnt stop the misfire on cylinder 3....what else could it be?? Bad coil? Ditzy? (I have spares of both..I think..I know I have a coil)

I am also going to SeaFoam Lucky both in the crankcase and fuel tank. Bucky is getting the same treatment after an oil change.

This is the first time I have tried the SeaFoam ..used MMO before...I hope it helps.

Any other tips would be greatly appreciated....geesh I feel like the EA81 dufus of the board

#2 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 13 May 2005 - 06:57 PM

Carb cleaner,n' all that is going to do it wonders.Clean the old gas out.check all the lines.blow them out or replace what's easy enough.Fuel filter(s),does the '82 have 2 filters?And does it have the third fitting for vapor seperator(?).


Check disty for wobble.THe tune up kit will work wonders.Drain oil and heads too,maybe after a treatment if you use one.Get the coolant system flushed,intall a T fitting for flushing the heater core.Remember,you're in this for the long run.Avoid doing things twice or the expensive way.

Belts,those on the car have been drying out.

Check the ASV reed valves(chewed ends or bent,broken) and the plastic silencer downstream(melting,cracking).

Call me after 2PM if you need me.Good luck.

#3 moosens

moosens

    Psychotic Subathusiast

  • Members
  • 1,234 posts
  • Bridgeport CT

Posted 20 September 2005 - 12:00 AM

Yikes,that carb was dirty,but it cleaned up real nice and quick...just looked yucky...waaaaaagh!....


I just took an old filter off tonight.It had the same undercoating on as the car....yikes! I ran a bottle of CD2 in the case for the ride up to Milford,drained and changed.
Still blowing that smoke.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users