Jump to content

Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse

- - - - -


  • Please log in to reply
2 replies to this topic

#1 MTSuby


    USMB is life!

  • Members
  • 208 posts
  • Helena

Posted 11 October 2007 - 11:23 AM

Sorry, stupid question, but after replacing my heater core (I had to disconnect the battery) my battery (I think) clicks every time I turn the key to auxilary. It starts fine and all that, but I can hear it click every time I turn the key, I can do it over and over and it keeps clicking when I turn it to auxilary. Did I reconnect it in a weird way or something? It didn't do this before.

#2 backwoodsboy



  • Members
  • 1,058 posts
  • upstate NY, in the woods

Posted 11 October 2007 - 12:32 PM

If you had a bad connection, (loose, etc.) you may be hearing a small spark jump, which you'll want to take care of right away.
I would personally suspect its a relay somewhere that is clicking, and you just never heard it before.

I'd find out EXACTLY where the sound is coming from... and go from there.

keep us posted.

#3 MTSuby


    USMB is life!

  • Members
  • 208 posts
  • Helena

Posted 11 October 2007 - 01:18 PM

Alright, thanks. I'll pay attention to where exactly it is.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users