Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

FT4EAT early model duty sol. C question


  • Please log in to reply
9 replies to this topic

#1 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 20 December 2003 - 06:09 PM

I have an 89 4EAT with full time 4wd
I drive on completely snow covered roads at times.
a) I would like to control the rear drive via modification to the signal sent to the duty solenoid for rear shaft drive (DS C).
I have been reading in my FSM about the system and it appears the duty solenoid controls the drain for the hyd. clutch pack.
If this is the case wouldn't simply opening the circuit to the duty solenoid cause the clutch pack to lock up?
B) Has anyone experimented along these lines?
c) another "trick" I was comtemplating was to modifiy the signal from the VSS on the rear drive, thus fooling the TCU into thinking the front wheels where spinning at a faster rate than the rears and thus locking the rear drive.
d) I know this is an "Old Gen" wagon (1989 GL-10 turbo) but I would also like to know where the TCU is located.
Thanks for any help in this endeavor


#2 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,654 posts
  • Houston, Tx

Posted 20 December 2003 - 10:09 PM

People have played around with this before.

Simply opening the circuit on the duty c solenoid will force 50/50 split all the time.

There's been talk about it not being the best for the duty c solenoid, but if it's occasional and on snow, I wouldn't be too concerned.

I'd just find the line for the duty c solenoid and wire a switch in line or a relay. I'd probably go with the relay route so the switch (if lighted) doesn't interfer with the signal.

#3 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 21 December 2003 - 08:18 AM

Thanks Josh, I tried a search before posting and came up lame.
So what I read is correct. I would like to hear more on why/how the solenoid would be hurt. (Voltage / current spike when switching possibly?)
Now the TCU may not like having an infinite resistance on it's output (there must be some protection built in as wires do break and connectors do go open).
I like the relay option but with the addition of a resistor across the N/O contacts. I could measure the pure resistance of the coils and match that.
Although I realize the signal sent ot the DS is AC at a freq of 50 Hz and it would realy want me to match the impedance not the pure resistance, atleast it would be looking at some resistance.
I also like the light idea, wired across the coil of the relay.
I plan to fit a gear shift from a push button 4wd (3AT) I have, and wire that button to operate the 50/50 split.
It would be nice if I could keep this all inside the cockpit, that is why I would like to find the TCU. Under the pass. seat maybe?
Thanks again for the reply


#4 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 21 December 2003 - 04:12 PM

tried another search for "duty solenoid"
large time score
There are some different opinions as to how DS C works.
It does over all look like disconnecting the harness
will indeed put the car in a 50/50 split (similar to the old style 4wd lever models Brats, hatches, GLs ect in 4wd Hi)
The big difference comes in descibing what DS C does.
My belief is the when DS C is signaled, (up to a 95% duty cycle) it opens a bleed for the hyd presure to the clutch pack,
thus
no signal = no bleed=full line pressure to the clutch pack =. full engagement of the rear drive


#5 dashton

dashton

    USMB Regular

  • Members
  • PipPipPip
  • 43 posts
  • Springville, Utah

Posted 23 December 2003 - 09:26 AM

Skip - do a search for user "patcal" and then go to his post of "starting to hate this tranny". There are a couple of replies there about how to do the switch you're talking about. I've installed it in my legacy and it works great, push the button and it locks it up. You can also look at the legacy central board, that's where I found the original info to do mine. Dave

#6 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 23 December 2003 - 11:13 AM

Thanks Dave, I read that thread earlier. Sounds like he has wiring problems, his voltage readings show the solenoid is not getting juice and is therefore not draining the pressure from the pack and it is causing the bind.
The last post was over a month old so I didn't reply.
The key here is the fact that DS C is a drain port, not an activation port.
In the begining I thought when the solenoid got a signal it activated the rear drive, this is wrong.
When it gets a signal it releases the pressure to the rear drive clutch pack, thus the switch works.
Sounds like you know a bit about hese 4EATs, have you seen this post by chance?
http://usmb.ultimate...=&threadid=9159
Thanks again


#7 dashton

dashton

    USMB Regular

  • Members
  • PipPipPip
  • 43 posts
  • Springville, Utah

Posted 23 December 2003 - 02:04 PM

Skip – here’s what I know and what I’ve done: The TCU is located right under the dash on the driver’s side. It has three connectors in the bottom. One of the wires goes directly to the duty C solenoid and is white with a black stripe and is in the connector closest to the firewall. Here are some links to Legacy777’s website where you can see the pinouts. I think it’s connector B33 terminal number 3. I found it using my neighbors Chilton manual.

http://www.main.expe...U_I-O_page1.jpg
http://www.main.expe...U_I-O_page2.jpg

As I understand it, the solenoid controls a valve that ports fluid to the clutch. When there’s 0 voltage to the solenoid it opens, sending fluid to the clutch and locking up the rear wheels. When there’s 12 volts to the solenoid it closes, releasing the clutch and rear wheels. As to your idea of it being a drain valve, it’s possible it could work that way, I don’t know for sure. Regardless, 12v = front wheel drive, 0v = four wheel drive. This opens up all kinds of possibilities for a switch in the line. For example, in my ’90 legacy I have replaced the height switch for the air suspension (which I removed) with a switch for the AWD. I used a defroster switch from a junkyard legacy which snapped right into place. I just spliced it into the line going from the TCU to the solenoid. When the switch is pushed in it makes a connection, putting the car in computer controlled AWD. When the switch is out, it breaks the connection putting the car in full time 4WD. And it sure goes in the snow in 4WD. Just don’t drive in on the pavement with it locked up – very hard on all the drivetrain components. You could also wire in a three position switch to do the following:

Pos 1: 0v (no connection) = 4WD
Pos 2: connected = computer controlled AWD
Pos 3: 12v supply line = front wheel drive

I guess if you’re smart enough you could use some type of variable switch to control exactly how much power is transmitted to the rear wheels (I think the WRX STI does this) but to me it doesn’t matter. I either want it AWD or 4WD depending on if I’m driving on or off road.

The only downside to using the switch is that the next time you start the car you’ll set a transmission error code because it thinks the solenoid is dead. If you’re wondering why I did this to my car, it’s because the AWD doesn’t work. I found a post on legacy central where somebody else had the same problem and he fixed it this way. It’s worked great for me so far, although I’m planning on eventually fixing the problem. I think I’ve got a bad TCU or bad speed sensor – for some reason it doesn’t change the voltage when a front wheel starts to spin. Anyway – hope this helps and good luck. Dave

fixed link

#8 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,654 posts
  • Houston, Tx

Posted 26 December 2003 - 01:46 AM

I've been away....but you guys seem to have things under control.

Everything I've read that you've guys posted is correct in the operation of the duty c solenoid.

#9 Skip

Skip

    Flatuous Blather

  • Moderator
  • 8,991 posts
  • Latrobe, Pennsylvania

Posted 26 December 2003 - 10:35 AM

Thanks Josh, and thanks for the relay idea.
Going on with what Dave says about throwing an error code if the DS is left disconneted.
Two lame ideas come to my feable brain
The relay could be a drop relay that is reset when the ignition is off (something like the cruise control "on" system)
Or
The NO contacts could be wired to a resistor eqaul to the resistance value of the DS coil.
I am seeing a DS A error now and am comptemplating removing the valve body to correct it - after it warms up a bit.
Thanks for all the replys


#10 Legacy777

Legacy777

    Moderator

  • Moderator
  • 12,654 posts
  • Houston, Tx

Posted 27 December 2003 - 12:48 AM

You may not want to put a resistor in there. If the ECU sees the resistance is good, and tries to send signals to it, and it doesn't respond....it may cause other issues.....

The relay dropping when ignition goes off is a good idea. To elaborate. I think the cruise type thing is setup in the switch, purely an electrical switch vs. mechanical/toggle. Doing something like this would reset the AWD circuit and leave it untouched when power is cut. I'd probably go this route. You should be able to find a generic push button electric switch somewhere.

Yeah, you should be able to get at those duty solenoids pretty easily. I don't remember if you even have to drop the valve body....been too long since I had mine out.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users