Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

2005 Outback high beam issue


  • Please log in to reply
1 reply to this topic

#1 davidv

davidv

    New User

  • Members
  • PipPip
  • 17 posts
  • nederland

Posted 20 June 2009 - 08:48 AM

We went with the 2005 Outback LTD. and driving home I noticed that the high beams work when pulling toward you, but when I push forward so they are on consistently, it clicks into place but the high beams don't come on.

Could this (please!) be a simple relay problem with an easy fix?

#2 Cougar

Cougar

    Elite Master of the Subaru

  • Members
  • 6,340 posts
  • Anchorage

Posted 21 June 2009 - 01:12 AM

Since the switch is working in one direction but not the other it appears the trouble is with the switch.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users