Jump to content
Ultimate Subaru Message Board

Recommended Posts

'96 Legacy L AWD Wagon with its original 2.2, 110k on the clock.


I started getting a very strong fuel odor in the cabin. I haven't had much time to work with it, so I wasn't able to check it out until after it sat all night. When I checked, there was no fuel anywhere, but once I started it up, the odor was back. I drove it this way for another, oh, 100-200 miles with no noticible decrease in fuel consumption, or any other symptom that there could be a problem. On the way home last night, I used about a third of a tank to go 40 miles and gas was, quite literally, dripping on the ground as I drove up the driveway. Upon inspection, fuel was pooling on the head under the injector. When I turned the key back to the run position, fuel appeared to be streaming from under the cover that holds the injector in place.


My first observation was that the bolts that hold the cover on the injector were very loose -- less than finger-tight. I tightened them and tried again with the same fuel leakage. After disconnecting the wiring and removing the bolts, I pulled the injector and inspected it. I didn't see any obvious cracks in the body of it, but the o-ring appeared to have a hunk missing out of it. I put the injector back in and closed it up for the night and vowed to hit KOI today and grab a new set of o-rings and a new top seal for it.


This morning, however, I thought it might be a good idea to test *just* to make sure. I put the top seal on, and bolted the injector cover back on. Without connecting the wiring harness, I turned the key to the "run" position, but did not start the motor. No fuel leaking, but I heard the pump pressurizing the system. I turned the key off, connected the wiring harness, and then turned it back to "run", again, without starting it. No fuel leak. At this point, I'm getting a little miffed that it's not leaking, so I start the motor. Still no leak, but the motor was running slightly rough and the CEL was lit. It didn't seem to be sputtering so much as the idle speed was hunting -- it would idle at 1200 for a second, then drop to 800, then back up to 1000, drop to 700, rise back to 1200, and then I shut her down.


I don't have an OBD-II decoder in my garage (although, I really need to get one at this point), and I was out of time before I had to get myself to work, but I'm a little baffled by the lack of a leak the second time around. I'm planning on picking up the new o-ring set tonight, replacing it, pulling the negative battery cable for fifteen minutes or so, and then giving it another try to see if that does stops the gush of fuel and the erratic idling. My thought there is that the computer was tripped to a missing injector when I put it to the run position with the harness disconnected, and that by clearing it out via removing power to the ecu, it will start fresh and everything it expects to see will be in place. I'm explaining away the lack of a leak the second time by just a lucky placement of the o-ring when it went back in so that it's not in a position where the damage is causing a leak yet.


The reason for this post, though, is that I'm not sure on either of those counts, and I'm looking for any other WAGs or anything else I should check or be wary of. Any help is greatly appreciated!



Share this post

Link to post
Share on other sites

After an excruiating wait from the stealership (and $20 worth of $5 rubber bits), I put the o-rings on the injector and re-installed. Oddly enough, the battery was completely dead (no doors open, and I checked the newbie switch). The car had been sitting for a little less than a week, but I still found that kind of strange. I suppose the battery could just be getting somewhat weak since I'm only showing about .3 amps being drawn with the key off. After charging up the battery though, I couldn't get it to start. I tried to roll-start it and when I dumped the clutch, it locked up all four and screeched to a halt. So, I started pulling plugs and the plug on the cylinder with the formerly leaky injector was soaked in fuel. After disconnecting the battery, I put a wrench on the crank pulley and hand-rotated the engine, causing fuel to geyser out of the open spark plug thread. Hydrolocked. After re-installing the plug, the car started up just fine, if a bit rough at first. I drove it around to charge the battery, and once I got it back to the garage, I pulled the battery cable. I put the battery cable back on this morning, and the CEL was off, and the car runs great once again.

Share this post

Link to post
Share on other sites

I would check that current draw again because .3 amps or 300 milliamps is too much draw on the battery if it stays that way. I seem to remember someone else saying they had a similar problem but the .3 amp drain changed to a lower safe value after some time. Like the car went into a sleep mode after some time. I look for problems if the current draw is greater than .08 amps or 80 milliamps, which is safe.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now