Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

messed up tranny oil change


  • Please log in to reply
3 replies to this topic

#1 alxborg

alxborg

    New User

  • Members
  • Pip
  • 4 posts
  • NC

Posted 04 March 2004 - 07:40 PM

I drove up my ramps to innocently to change my fliud as descibed to me by a pro however I must have not heard him correctly,,,so...I drained to fluid and what I thought it needed(nearly a gallon all at once-and before I knew- fluid everywhere!! NOW IT IS REALLy PISSED AT ME -CAN'T BLAME IT!!!Now it will not move much and is making clicking sounds..like air in valves???Any help would be greatly appreciated. I siphoned it down to nearly the stick level and still no luck. Have mercy on me-I do know better!

#2 speedbump

speedbump

    USMB is life!

  • Members
  • 179 posts
  • North Vancouver,Canada

Posted 04 March 2004 - 08:44 PM

did you start the car and then....shift to reverse and hold for 30 sec,shift to drive and hold for 30 sec,shift to second....

this purges air out of the system.check yourfluid level after running through all the gears
cheers

#3 TROGDOR!

TROGDOR!

    Pastor of Muppets

  • Members
  • 2,106 posts
  • Morgantown, WV

Posted 04 March 2004 - 09:04 PM

Did you even drain the fluid? There is a plug on the bottom front of the transmission pan; drain it until it's empty, then put the PROPER amount of fluid in, and try it again.

If I remember right the max capacity is about a gallon. Start with 2 quarts and work your way up. Be sure to check the fluid with the engine running.

#4 88rxsedan

88rxsedan

    Subaru Fanatic!

  • Members
  • 385 posts
  • san antionio

Posted 05 March 2004 - 02:27 AM

did you accidently drain the engine oil or the diff oil?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users