Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
* * * * * 1 votes

O.C.D.'s 1980 Brat - "The Squirrel"


  • Please log in to reply
215 replies to this topic

#176 Reza

Reza

    USMB Regular

  • Members
  • 137 posts
  • Portland, OR

Posted 29 July 2013 - 11:55 PM

Forgot to add I have a Weber and adapter plate coming this week. I was missing too many parts on the Hitachi and I think it sucks anyway, lol. So the carb is outta there once the engine and tranny go back in. Should be firing it up soon!

Awesome, your killin it, keep the updates coming.



#177 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 30 July 2013 - 07:49 AM

Thanks Reza.  It has been so hard finding time but I really am trying.  I want this thing running like a top and in primer/paint before the end of summer.  Looks like I should make goal for sale.



#178 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 01 August 2013 - 07:28 AM

Got a nice little surprise in the mail yesterday.  Cannot wait to put this on.  And since I love pictures I thought I would show everyone what a completely brand new Weber DGEV 32/36 Carb and adapter plate look like.



#179 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 01 August 2013 - 07:32 AM

Some things I see and have researched as needing to be fixed:

 

The Hitachi side (intake manifold) gasket is not cut right and will require modification.  This portion of the adapter will be Dremeled as well to be more linear in transition to the manifold.

 

The carb to adapter gasket looks good.

 

But the adapter on the carb has a shoulder that will definitely affect flow.

 

This is on the 36 side.  32 side is no problem.

 

So I will Dremel this as well to get better flow.

 

 

 



#180 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 01 August 2013 - 07:36 AM

I also got the transmission cross member installed last night.  The new bushings were a pain to get installed.  And I guess I was due for some screw ups.  The threads on one of the cross member bolts got cross-threaded and I could not get it to seat properly.  My only option was to go for it and I did.  That paricular bolt will never be coming out.

 

On the other side the captive nut let go after I almost got the bolt all of the way in.  So that will never come off either (unless cut off and a new nut welded inside the unibody some how).

 

So for all I have done, these (so far) have been my only screw ups.

 

On a side note I ordered new sway bar bushings from Rock Auto.  They typically have them but when I go to order they say sorry.  But the order went through and we shall see.  New fan switch as well.

 



 

1980 SUBARU BRAT 1.6L H4

ACDELCO 45G0542 Stabilizer Bar Bushing

BECK/ARNLEY 2011381 Radiator Fan Switch
RAYBESTOS 5501042 Stabilizer Bar Bushing


Edited by O.C.D., 01 August 2013 - 07:55 AM.


#181 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 02 August 2013 - 01:11 PM

Getting the hoist in a couple hours.  The Squirrel will have a clean bill of health as far as the drive-line goes.

 

I don't know why I am so excited to throw it back in.  Oh wait,.........it is because I have been working on it for three months, lol.



#182 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 05 August 2013 - 07:50 AM

Well, the engine and trany are back in!!!  Rented a hoist last Friday to throw it all back in but we quickly learned that the trans cross-member was in the way.  And since I buggered up two of those bolts it was not coming off.  SO we took it apart and did each part separately.  Waste of $30 but not really considering it went in easier.

 

Here are the cleaned up mounts and engine cross member.

 

And a shot of us trying with the transmission mounted.

 

Two days later (took a day off) and lots of work I have almost everything hooked up. 

 

The main harness loom was coming off so I thought it would be a good time to re-loom it with split loom.  I love doing this as I have done it on almost everything I work on.. Just cleans it all up.

 

One of my biggest goals was to flush/clean/paint the radiator.  So I did, lol.  Cleaning was fairly easy.  Some hose love and air compressor.  VHT case paint for the color.  New Beck Arnley radiator switch.



#183 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 05 August 2013 - 07:59 AM

Cleaned up the exhaust more and scrapped the flanges free of red gasket sealer.  New gaskets fit odd but they cover the hole and mating surface so oh well.

 

Started the Weber swap as well.  Lots of work to get this the way I want it. 

 

Had to port the intake manifold for the adapter as it was off as mentioned above.  Like the slips of the Dremel.  Love that and need to fix that now.

 

Adapter has been ported heavily. Intake side.

 

Carb side as mentioned above was really bad for the transition.  Lots of Dremel love here and in the end it is much better.  So from this to this.

 

 



#184 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 05 August 2013 - 08:12 AM

Forgot to add....

 

Charcoal canister is completely gone now and most of the crappy emissions.  But I am stuck on some figuring out of things.

 

1.  The vacuum port for the brake booster still connects the same way.  I got that.

2.  The vacuum advance for the distributor has two hoses, which one do I connect to the Weber?

3.  The clutch return spring connects to the fork and what?  I can't seem to recall.

4.  With the clutch cable installed I have no clutch throw so I am thinking the cable came off the pedal assembly?  Any pointers on this?

5.  Will not having the emissions crap plugged into the harness cause it to throw lights? 

 

Many more questions but I thought of these first.

 

Thanks.

Jon


Edited by O.C.D., 05 August 2013 - 08:16 AM.


#185 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 13 August 2013 - 08:08 AM

So I am having a fuel issue with the carb setup.  Got her running and then she dies.  So I thought I would post the same pics in here if anyone is interested.

 

Cap and rotor with wiring to 1 and 3 cylinders.  New plugs by the way.

 

Cap and rotor with wiring to 2 and 4 cylinders.  Also the lead for the choke.

 

Stock PVC and 2 and 4 wires.

 

Fuel in on the Weber - only hose that is left, lol.  No return.

 

Choke wiring.  Tied into the Hitachi vacuum solenoids.  Blue wire from the harness.

 

Passengers
PVC vent - stock.  Also you can see the vacuum cap on the distributor. 
I have the outside port being used for the carb vacuum.  Unless I am
wrong this is advanced.  The other is retard.

 

Again Drivers side PVC - stock and will go to stock airbox.

 

Pic of the one fuel line.  New fuel line I might add.

 

Timing on the cap and rotor set back to middle.  I cannot say if this is stock though?

 

From behind the intake manifold - EGR capped off, as well as the avs

 

So,  let me know what ya think.  It has been made mention of the fuel pump.  That might be my plan so far?

 

Thanks.

Jon

 

 

 



#186 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 14 August 2013 - 10:04 AM

After much research again about the fuel issues it appears that I was not aware of a "safety precaution" that was in place for these old Subies.  The Ignition switch fires the fuel pump when the key is turned on to start the engine.  Once the starter is kicked off and the key returns to the run or on position the alternator takes over the electricity needs for the pump.  Seeing as how my alternator has been clicking and it is original I sprung for a remanufactured alternator and a new Accell Super Stack Coil.  My coil was original as well.  The voltage regulator was replaced before I got the Squirrel.  So hopefully that should help with the issue.  I also have a new fuel filter that will be going on.

 

I will get this to work!

 

New coil:

Accelcoil_zpsb7511329.jpg

 

Also, what is this supposed to be connected to?

IMG_4062-2_zps7e2452ed.jpg


Edited by O.C.D., 14 August 2013 - 10:24 AM.


#187 Reza

Reza

    USMB Regular

  • Members
  • 137 posts
  • Portland, OR

Posted 14 August 2013 - 03:05 PM

that connects to the back of the alternator.



#188 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 14 August 2013 - 03:46 PM

If I am that stupid then I really feel sorry for myself.  I could have sworn I connected that.  Will check in a bit, lol.



#189 Reza

Reza

    USMB Regular

  • Members
  • 137 posts
  • Portland, OR

Posted 14 August 2013 - 03:59 PM

Ill go pop my hood haha, pretty sure that's it though.>>

>>>>> just checked, and yeah Thats the only connection that is in that area, at least on my 79.


Edited by Reza, 14 August 2013 - 05:11 PM.


#190 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 15 August 2013 - 07:49 AM

It was indeed not connected obviously.  Connected it and turned her over and nothing again.  I really think I am not getting any spark?  Could I have fried my ignition coil not having that connected?  Either way I have the new coil and alternator and will just swap them.

 

I am so pissed that this thing wont start?!  All of this work and now it comes down to electrical BS, again.

 

When I did try and start her last night I was definitely getting fuel as the carb was smelling of raw fuel.

 

Gotta be the coil or alternator?



#191 turbosubarubrat

turbosubarubrat

    2nd gen hoarder

  • Members
  • 1,304 posts
  • Sandy, OR

Posted 16 August 2013 - 01:28 AM

are you getting spark to the spark plugs? if not work your way back to see whats bad.



#192 Subieguy

Subieguy

    Subaru on the brain!

  • Members
  • 905 posts
  • Paso Robles, California

Posted 17 August 2013 - 11:15 PM

Did you figure out where the clutch return spring goes? From the clutch fork to the drivers side of the intake manifold. There is a notch right there on top next to the PCV spot on the manifold. That's where it goes.



#193 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 19 August 2013 - 09:00 AM

Got it all figured out last night.

 

New alternator and ignition coil did the trick.  Starts right up and runs great!!!

 

Got the new clutch cable in and was able to drive her around last night.  Wow what a difference from before.  The whole car seems more smooth.



#194 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 19 August 2013 - 09:18 AM

oh, and FYI to anyone doing the WEBER swap.  DO NOT USE THE GASKET FOR THE MANIFOLD THAT COMES WITH THE KIT IT WILL LEAK!!!

 

I had read that before but I didn't heed the advice.  Had to take the carb off and redo all my hard work cause it was leaking antifreeze.  SO DON"T USE THE WEBER GASKET!



#195 BratRod

BratRod

    USMB is life!

  • Members
  • 507 posts
  • Dallas, Texas

Posted 19 August 2013 - 12:02 PM

Yay! :bouncy:

#196 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 19 August 2013 - 02:20 PM

And a quick video.

 

 

Up for sale soon!!!



#197 Mykeys Toy

Mykeys Toy

    Subaru Master

  • Members
  • 2,059 posts
  • South Prairie, Wa

Posted 19 August 2013 - 07:22 PM

Nice!  I thought all that hard work was for you to enjoy not to unload.



#198 1982gl4

1982gl4

    1000+ Super USER!

  • Members
  • 1,411 posts
  • Worcester, VT

Posted 19 August 2013 - 07:24 PM

I really like what you are doing with this! keep up the good work man. Glad you got it running!



#199 O.C.D.

O.C.D.

    Subaru Fanatic!

  • Validating
  • 690 posts
  • Colorado Springs

Posted 20 August 2013 - 07:26 AM

Nice!  I thought all that hard work was for you to enjoy not to unload.

 

I thought so as well.  The Baby has really changed my priorities in a good way.  The Squirrel will do me no good at this point in my life.  She will just sit there and take up space.  I am not sad though; I love the project and have had a blast.  She will be a good catch for someone.

 

I really like what you are doing with this! keep up the good work man. Glad you got it running!

 

Thanks, been a long rebuild, lol.



#200 bendecker

bendecker

    USMB is life!

  • Members
  • 313 posts
  • Lakeside, CA

Posted 20 August 2013 - 11:49 AM

After having kids, and also having to compete with a gazillion SUVs on the CA highways in my little Brat, I went the route of just letting her be a garage-filler for the most part. I only drive her occasionally around town, or to camping adventures on a road that's 55mph, or up into the hills on fire roads behind our house. For the most part, she's just a  pretty garage ornament. Yep. Kids change priorities.... but they love riding in the back!


Edited by bendecker, 20 August 2013 - 11:49 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users