Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

List your problems from use of the Subaru coolant additive


  • Please log in to reply
6 replies to this topic

#1 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,431 posts
  • Near Cortland NY

Posted 03 December 2012 - 01:22 PM

I thought it might be useful to have a place to note problems strongly suspected to be caused by the subaru coolant additive, a.k.a Holt's RadWeld.

I know what the goop looks like because I'm trying it out in my H6 (external head gasket coolant weep), but the problem was on my wife's 2005 Forester, which I assume had the magic goo added by the dealer after it had its head gaskets replaced (external oil leak).

Anyway, on a trip the rad was not holding pressure, too much coolant was being sent to the overflow reservoir, and it was not sucking coolant back up from the overflow.
Problem was the cap.

Checked the cap under magnification, looks like some of the magic goo collected on the metal plate that seals under pressure and allows the coolant to be sucked back in.

#2 porcupine73

porcupine73

    Obligate carnivore

  • Members
  • 4,950 posts
  • Buffalo, NY

Posted 03 December 2012 - 03:37 PM

I know some people don't like the stuff but I'm not sure. I've been using it in all my soobs for many years, so far I haven't seen any issues from it. There was a TSB or note on Endwrech about the rad caps, something about making sure no debris is between the rubber part and the metal underneath, I think it talked about using basically a toothbrush to make sure it is clean under there.

#3 3Pin

3Pin

    Eat, Live, Breath Subaru

  • Members
  • 359 posts
  • Milwaukee

Posted 03 December 2012 - 10:32 PM

I haven't had any issues with it and have used it on the 2000+ cars where recommended.

I recently bought a car that the previous owner attempted a bottle of HG repair several times. I had to blow out the heater core to get heat. but fortuantley everything else is OK.

How many miles on your 03 LLBean? I have an O2 LLBean with 104 and so far all is OK.

:drunk:

#4 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,431 posts
  • Near Cortland NY

Posted 04 December 2012 - 09:39 AM

My beaner has a bit over 193k, recently showed some damp/wet green spooge at the head gasket, but the edges of the head gaskets have been greenish from coolant for probably 40k miles.

The problem with magic additives is when they don't work, some goober always says 'well then maybe 4 will work!'.

#5 avk

avk

    My Outback is bigger than yours

  • Members
  • 959 posts
  • Somerset County, NJ

Posted 04 December 2012 - 01:36 PM

I am sorry I'm not up to speed on this. Has it indeed been established that the Subaru additive is RadWeld?

#6 porcupine73

porcupine73

    Obligate carnivore

  • Members
  • 4,950 posts
  • Buffalo, NY

Posted 04 December 2012 - 02:11 PM

Yes. It even says Holts right on the bottle. Look at this pic scroll down and there's a side by side comparison. It says Holts on the Subaru bottle.

#7 CNY_Dave

CNY_Dave

    03 LL Bean H6

  • Members
  • 1,431 posts
  • Near Cortland NY

Posted 04 December 2012 - 03:46 PM

Yep, mine from the dealer said 'Holt's' right on the side...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users