Jump to content

Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse

- - - - -

Engine trouble after installation of new battery

fuse data link check engine

  • Please log in to reply
3 replies to this topic

#1 Cold Mama

Cold Mama


  • Members
  • Pip
  • 1 posts
  • St. Paul, MN

Posted 15 October 2013 - 11:03 PM

I'm posting this one because I found my own answer to an annoying situation and didn't find this same problem listed elsewhere.  Hope it helps someone else.  


Our 2005 Legacy sedan was in at my (previously) trusted oil change place.  The battery was 5 years old, at the bottom of the marginal rating, we live in Minnesota and they had a good price on a good battery = new battery. They promised they had the right equipment to keep a small charge so I wouldn't have to reset the ECM.  When I started it up, not only were the radio pre-sets gone, I had a rough engine and a solid check engine light - You can guess I wasn't happy.  


I did the ECM reset, but the check engine light wouldn't clear.  I took it to an auto parts place and they couldn't get a reading from the Data Link Connector / ODII. I called my local dealer to get the location of the fuse they might have blown and was told there are no fuses related to the ODII - Bring it in and the will run it through a full diagnostic $$$.  Well, I'm not a sucker (there are/should be fuses protecting all electrical equipment) so I spent the evening with the schematics (bought a pdf of the repair manual from subarumanuals on ebay a while back) and traced down some possibilities.  MB13 (7.5 fuse in the motor compartment, far right side of the fuse bank, 3rd from the bottom) was blown.  Replaced it and all is well.  


My guess is they ran too much juice through their little gizmo - So my new question is did they have the choice of power settings and mess up or is it unusual for this to be on a little 7.5 amp fuse...  Don't know, but their (lack of) response to their screw-up has me back making appointments for oil changes at the local shop.

#2 Fairtax4me



  • Members
  • 13,031 posts
  • Charlottesburg, VA

Posted 16 October 2013 - 01:18 AM

My guess would be they did put in the "memory saver" dohickie, but they foolishly let the positive battery cable touch the chassis or the negative cable after they removed them from the battery.
Even though the memory saver is a small battery it still has enough juice to blow a fuse (even an alkaline AA 1.5v battery can blow a small automotive fuse).
By letting the battery cables touch this creates a short of the DLC power pin circuit. This pin always has battery voltage, even if the key is off. It's connected directly to the battery through that 7.5 amp fuse (and a larger fuse under the hood). This makes the DLC a prime place to plug in a memory saver. But when the battery cables touch it essentially creates a short circuit through that fuse, since there is no resistance in that circuit. Low resistance = high amperage = blown fuse
Now that the fuse is blown, that circuit is dead, no power from the memory saver can reach the radio or the other components it is supposed to supply.

The ECU monitors that circuit, which is why it lit the CEL. Fuse replaced, now a scanner should be able to connect to read any codes.
The ECU may not set a "code" for a problem on the DLC power circuit, often the "code" is that it just turns the CEL on.

#3 ivans imports

ivans imports

    1000+ Super USER!

  • Members
  • 2,954 posts
  • lumby bc canada

Posted 16 October 2013 - 09:26 AM

I use a memery saver is only for 05 and up cars with drive by wire to save idle settings and ecu memery on pre 05 cars no piont. But very critical that 1 the key is off all the time two nothing else at all is on and 3 negative last to be disconected and last to be reconected. If you putt + termanal on after - termanal can damage ecu or other curcits had a 07 outback that customer just riuned ecu by changing his own battery hooked up + last and small spark and check engine light and no idle. My memery saver is only 10 amp so any more drw than that will pop fuse

#4 Bushwick


    1000+ Super USER!

  • Members
  • 1,406 posts
  • Ohio Akronish

Posted 16 October 2013 - 01:03 PM

As far as your OBDII port not getting recognized, I've had this happen in TWO other completely different (model/make/year) cars that worked fine one minute, then not the next. What was happening is when the person attaching the scanner plug, they were pressing it in at an ANGLE. This will cause the pins in YOUR OBDII connector to back out slightly, causing a NO read from the scanner.


What I suggest is unscrewing the OBDII port connector so it's dangling, then look very closely at the back side where the wires get crimped to the pins. They should all be evenly lined up. Look for the crimping on the pin/pins that is NOT lined up. Simply press back into the connector. LEAVE port dangling, and try to get another code reader hooked up, only insist you do it. Just be easy with the connector and try to insert as straight as possible. If the pin is really loose, it'll back out again as soon as the scanner is attached. In that case, once the scanner is hooked up, manually push the pin back in. The connection will be completed and you can scan for codes. Both cars I owned (Ford and Saab) had this happen at completely different places and years. In both cases I knew the OBDII worked, so after investigating closer I found the pins are easy to push out. You might have several pins out (talking like a millimeter here, they appeared to still be connected) so look closely. The fuse being blown might be a separate issue.

Also tagged with one or more of these keywords: fuse, data link, check engine

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users