Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

code 12?


  • Please log in to reply
2 replies to this topic

#1 nutt7

nutt7

    certified hoser!

  • Members
  • 241 posts
  • Tempe

Posted 13 May 2004 - 12:50 PM

86 turbo wagon-

I pulled my codes due to the ECS light which sometimes makes a brief appearance on startup, and I got a code 12. Haynes says its the starter switch staying closed, I think. What exactly is a starter switch (what does it do)? where is it and how can I check it?

I am pretty sure it is not referring to the ignition switch...that doesnt make sense, and if that stayed closed, my car would not start, right? could it be that neutral switch or whatever that thing is? it says I have one on my 5spd...I dont know its purpose.

thanks,
eric

#2 stephenw22

stephenw22

    Certified Subaru Nut

  • Members
  • 877 posts
  • SK, Canada

Posted 13 May 2004 - 01:05 PM

As far as I know, that's a code that you get from starting the motor. My '85 has had code 12 for years with no problems.

#3 WJM

WJM

    SUBARU

  • Members
  • 7,828 posts

Posted 13 May 2004 - 07:14 PM

There is a pair of green connectors connected under the foot dash pannel. unplug that one pair. It will go away. Also, on my GL-10, it will cycle the fuel pump with the ignition on every 2-3 seconds...On...off....on....off...like so. Thats with the connectors connected. W/out...i turn it on, and it primes up...then it just sits. No ECS code after driving a while.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users