Jump to content


Welcome to Ultimate Subaru Message Board, my lurker friend!

Welcome to Ultimate Subaru Message Board, an unparalleled Subaru community full of the greatest Subaru gurus and modders on the planet! We offer technical information and discussion about all things Subaru, the best and most popular all wheel drive vehicles ever created.

We offer all this information for free to everyone, even lurkers like you! All we ask in return is that you sign up and give back some of what you get out - without our awesome registered users none of this would be possible! Plus, you get way more great stuff as a member! Lurk to lose, participate to WIN*!
  • Say hello and join the conversation
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Classifieds with all sorts of Subaru goodies
  • Photo hosting in our gallery
  • Meet other cool people with cool cars
Seriously, what are you waiting for? Make your life more fulfilling and join today! You and your Subaru won't regret it, we guarantee** it.

* The joy of participation and being generally awesome constitutes winning
** Not an actual guarantee, but seriously, you probably won't regret it!

Serving the Subaru Community since May 18th, 1998!

Guest Message by DevFuse
 

Photo
- - - - -

Screen display freezes: unable to use phone and nav functions


  • Please log in to reply
3 replies to this topic

#1 Mabthib

Mabthib

    Newbie

  • Members
  • Pip
  • 1 posts
  • Vernon BC Canada

Posted 02 October 2017 - 08:55 AM

My new 2017 Crosstrek has had the radio/display unit replaced once already and same problem is occurring. When the screen freezes nothing functions. If the car is turned off and back on the problem resolves, but this isn't an option on a highway. And lately the Bluetooth to the phone has stopped functioning (separate from screen freezing issue). Have had to uninstall the phone and reinstall. Any thoughts? The dealership has no answers and Suburu Canada referred me back to the dealership. I find it unlikely that two new radio/display units would both malfunction in the same way so think it must be something else.

#2 golucky66

golucky66

    Subaru Nut

  • Members
  • 568 posts
  • Barkhamsted Connecticut

Posted 02 October 2017 - 09:02 AM

My moms 2017 crosstrek is going in soon to have the radio replaced due to similar issues, and loss of functionality.
So i wouldn't be too surprised if it was the head unit again...

There's a lot of technology in those radios and if anything hangs it can cause the whole unit to crash until a reboot.

#3 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,897 posts
  • frederick, md

Posted 09 October 2017 - 04:55 PM

i had the same issue in mine, every once in a while, it just randomly locks up or refuses to fully connect to my phone. frequently, it stops playing music, claiming that there is no cellular data service, where i never have an issue with my pioneer stereo in my wrx. and the icing on the crapcake that is the factory stereo, the screen shattered when i touched it to select a pandora station. the display still functions, but the top layer with the touch sensors is what broke, so i can only use the steering wheel controls or the buttons around the screen. I am actually waiting to hear back from the dealership about that issue.. it is just a poorly designed head unit....



#4 subyrally

subyrally

    Trust your Turbo-Lust

  • Members
  • 2,897 posts
  • frederick, md

Posted 13 February 2018 - 01:05 PM

I know its been a while, but I have an update. the dealership said that they wouldn't cover the stereo replacement, so I got a Pioneer avh-4200nex head unit and installed that this past weekend. I had to get a couple adapters to make the steering wheel controls work with it as well as the reverse camera. I didn't realize that the harness needed an adapter for the antenna, so I had to order that and the usb adapter. I also need to do some trouble shooting on the reverse camera, the head unit gets the reverse signal, but the camera doesn't come on. and for some reason, the brake light on the dash is on, which tells me that something in the e-brake lever switch is wonky, I might have clipped a wire or disconnected something when I ran the parking brake wire from the stereo.

 

when it rains, it pours... or in my case, hail..

 

on a positive note, the pioneer stereo sounds way better and I can connect to my phone for music, calls, and navigation.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users